aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-02-16 17:36:47 +0100
committerJo-Philipp Wich <jo@mein.io>2017-04-08 14:31:27 +0200
commit5aa97e35dec1783c98d0f28502b2d16879ffc8ee (patch)
tree3bcf69f7cbc2c6b7574e8b4ce8de9dc41331e470 /package/system/opkg/Makefile
parent7099bb19b50d74d3a400aa3a60e0b7ba0157bc1e (diff)
downloadupstream-5aa97e35dec1783c98d0f28502b2d16879ffc8ee.tar.gz
upstream-5aa97e35dec1783c98d0f28502b2d16879ffc8ee.tar.bz2
upstream-5aa97e35dec1783c98d0f28502b2d16879ffc8ee.zip
opkg: switch to LEDE fork (#120, #551, #571)
Cherry-pick the following commits from master to bump opkg in LEDE 17.01: b65dc04712 opkg: switch to own fork to improve memory usage 55ffc38004 opkg: re-enable usign support 19720a6f03 opkg: fix handling conffiles in status lists 9e4555f58d opkg: fix stray printf() (#551) ebf846b005 opkg: mark as essential (FS#571) aedd5d5cb0 opkg: fix several package installation bugs 48ae44d033 opkg: gracefully handle missing $PATH, fix build warnings 1449b52f02 opkg: backport upstream fixes, code cleanups Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile92
1 files changed, 27 insertions, 65 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 39e6b4d058..110116971e 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -11,15 +11,14 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=opkg
-PKG_RELEASE:=17
+PKG_RELEASE:=1
+PKG_FLAGS:=essential
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=http://git.yoctoproject.org/git/opkg
-PKG_SOURCE_DATE:=2011-04-08
-PKG_SOURCE_VERSION:=9c97d5ecd795709c8584e972bfdf3aee3a5b846d
-PKG_MIRROR_HASH:=55e05270f3eb2f3aff5d3791463ce3d13b8197ca7b301cd58e731a249552c48f
-PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES = autogen.sh aclocal.m4
+PKG_SOURCE_URL:=https://git.lede-project.org/project/opkg-lede.git
+PKG_SOURCE_DATE:=2017-03-23
+PKG_SOURCE_VERSION:=1d0263bb40e3c099501fc1f2431907636230e7f2
+PKG_MIRROR_HASH:=1f527179e60b9404affa5f3c9c506d4249e085bf521f770819b8648273a1010c
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
@@ -27,21 +26,24 @@ PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_FLAGS := nonshared
-PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES
+PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH
PKG_BUILD_PARALLEL:=1
HOST_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+HOST_BUILD_DEPENDS:=libubox/host
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
define Package/opkg
SECTION:=base
CATEGORY:=Base system
TITLE:=opkg package manager
- DEPENDS:=+uclient-fetch +libpthread
- URL:=http://wiki.openmoko.org/wiki/Opkg
+ DEPENDS:=+uclient-fetch +libpthread +libubox
+ URL:=https://git.lede-project.org/?p=project/opkg-lede.git
MENU:=1
endef
@@ -55,16 +57,6 @@ define Package/opkg/description
opkg knows how to install both .ipk and .deb packages.
endef
-define Package/opkg/config
-config OPKG_SUPPORT_MD5
- bool
- default n
- depends on PACKAGE_opkg
- prompt "Support reading old md5 hashes."
- help
- Old opkg used md5s, new uses sha. This options enables understanding both while prefering sha.
-endef
-
define Package/opkg/conffiles
/etc/opkg.conf
/etc/opkg/keys/
@@ -74,29 +66,20 @@ endef
TARGET_CFLAGS += -ffunction-sections -fdata-sections
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
-CONFIGURE_ARGS += \
- --disable-curl \
- --disable-gpg \
- --enable-sha256 \
- --with-opkgetcdir=/etc \
- --with-opkglockfile=/var/lock/opkg.lock
-
-ifndef CONFIG_SIGNED_PACKAGES
- CONFIGURE_ARGS += --disable-usign
-endif
-ifeq ($(CONFIG_OPKG_SUPPORT_MD5),y)
- CONFIGURE_ARGS += --enable-md5
-else
- CONFIGURE_ARGS += --disable-md5
-endif
-
-MAKE_FLAGS = \
- CC="$(TARGET_CC)" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- HOST_CPU="$(PKGARCH)" \
- LDFLAGS="-Wl,--gc-sections" \
-
-define Package/opkg/Default/install
+CMAKE_OPTIONS += \
+ -DBUILD_TESTS=OFF \
+ -DHOST_CPU=$(PKGARCH) \
+ -DPATH_SPEC="$(TARGET_INIT_PATH)" \
+ -DVERSION="$(PKG_SOURCE_VERSION) ($(PKG_SOURCE_DATE))"
+
+CMAKE_HOST_OPTIONS += \
+ -DSTATIC_UBOX=ON \
+ -DBUILD_TESTS=OFF \
+ -DHOST_CPU=$(PKGARCH) \
+ -DLOCK_FILE=/tmp/opkg.lock \
+ -DVERSION="$(PKG_SOURCE_VERSION) ($(PKG_SOURCE_DATE))"
+
+define Package/opkg/install
$(INSTALL_DIR) $(1)/usr/lib/opkg
$(INSTALL_DIR) $(1)/bin
$(INSTALL_DIR) $(1)/etc/opkg
@@ -107,34 +90,13 @@ define Package/opkg/Default/install
$(VERSION_SED) $(1)/etc/opkg/distfeeds.conf
$(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
-endef
-
-define Package/opkg/install
- $(call Package/opkg/Default/install,$(1),)
ifneq ($(CONFIG_SIGNED_PACKAGES),)
echo "option check_signature 1" >> $(1)/etc/opkg.conf
endif
- mkdir $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/
endef
-define Build/InstallDev
- mkdir -p $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libopkg $(1)/usr/include/
-endef
-
-
-HOST_CONFIGURE_ARGS+= \
- --disable-curl \
- --disable-gpg \
- --enable-sha256 \
- --with-opkgetcdir=/etc \
- --with-opkglockfile=/tmp/opkg.lock
-
-define Host/Compile
- +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
-endef
-
define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
endef