aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/mtd/src/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-08-19 08:35:41 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-08-19 08:35:41 +0000
commit9f8042dd1f611cb0226c0e13cc26d6879f137d6a (patch)
treed50eb70e9fbb78619a069820f3eb8427bcfa4acf /package/system/mtd/src/Makefile
parentf9ccf89b13ac00aac7d741c62bca19beaa588951 (diff)
downloadupstream-9f8042dd1f611cb0226c0e13cc26d6879f137d6a.tar.gz
upstream-9f8042dd1f611cb0226c0e13cc26d6879f137d6a.tar.bz2
upstream-9f8042dd1f611cb0226c0e13cc26d6879f137d6a.zip
mvebu: add support for the Linksys boot counter (backport of r46690)
The u-boot boot counter was never reset after a successful boot, which sometimes could make some variables become out of sync. This patch adds support for the boot counter and enables auto_recovery unconditionally. Signed-off-by: Jonas Gorski <jogo@openwrt.org> Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46691 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/mtd/src/Makefile')
-rw-r--r--package/system/mtd/src/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/system/mtd/src/Makefile b/package/system/mtd/src/Makefile
index 27ac339005..40a165e4e6 100644
--- a/package/system/mtd/src/Makefile
+++ b/package/system/mtd/src/Makefile
@@ -10,6 +10,7 @@ obj.brcm47xx = $(obj.brcm)
obj.bcm53xx = $(obj.brcm)
obj.brcm63xx = imagetag.o
obj.ramips = $(obj.seama)
+obj.mvebu = linksys_bootcount.o
ifdef FIS_SUPPORT
obj += fis.o