aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/mtd/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2018-07-15 16:51:41 +0200
committerRafał Miłecki <rafal@milecki.pl>2018-07-15 16:51:41 +0200
commit0f54489f754e7bd34e0430c57a11b6a54740d58e (patch)
tree19b141f070b8e130685ed2192d26cfde42972cd4 /package/system/mtd/Makefile
parentb123921a92a957f08abb186e041aa38aa9328f3e (diff)
downloadupstream-0f54489f754e7bd34e0430c57a11b6a54740d58e.tar.gz
upstream-0f54489f754e7bd34e0430c57a11b6a54740d58e.tar.bz2
upstream-0f54489f754e7bd34e0430c57a11b6a54740d58e.zip
mtd: support bad blocks within the mtd_fixtrx()
Reading MTD data with (p)read doesn't return any error when accessing bad block. As the result, with current code, CRC32 covers "data" stored in bad blocks. That behavior doesn't match CFE's one (bootloader simply skips bad blocks) and may result in: 1) Invalid CRC32 2) CFE refusing to boot firmware with a following error: Boot program checksum is invalid Fix that problem by checking every block before reading its content. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'package/system/mtd/Makefile')
-rw-r--r--package/system/mtd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/mtd/Makefile b/package/system/mtd/Makefile
index 9ae03a77a9..969e1c711c 100644
--- a/package/system/mtd/Makefile
+++ b/package/system/mtd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mtd
-PKG_RELEASE:=21
+PKG_RELEASE:=22
PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)