aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/fwtool/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-11-09 14:33:13 +0100
committerPetr Štetiar <ynezz@true.cz>2019-11-11 16:37:13 +0100
commit4ba8f7b1ef1e4c0607185a41c06b51928c625d8b (patch)
treefa0d31cfe601301c0b900850131f59c808f832ba /package/system/fwtool/Makefile
parente97113d5e18c31050bc06f7c6b7a5c663b5f31a4 (diff)
downloadupstream-4ba8f7b1ef1e4c0607185a41c06b51928c625d8b.tar.gz
upstream-4ba8f7b1ef1e4c0607185a41c06b51928c625d8b.tar.bz2
upstream-4ba8f7b1ef1e4c0607185a41c06b51928c625d8b.zip
fwtool: update to latest Git head
Includes following changes: 9d9d4c284786 fix possible garbage in unitialized char* struct members dbc1b1b71b24 fix possible copy of null buffer and validation of unitialized header 76d53deef8bb crc32: add missing stdint.h dependency e5666ed3b47c add cram based unit tests abe0cf7de053 add initial GitLab CI support e43042507b4f iron out extra compiler warnings 5df0cd6e1523 convert into CMake project a7dc0526f819 refactor into separate Git project adds missing PKG_LICENSE field and converts the package build to utilize CMake. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/system/fwtool/Makefile')
-rw-r--r--package/system/fwtool/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/package/system/fwtool/Makefile b/package/system/fwtool/Makefile
index 283be8d77a..8397282392 100644
--- a/package/system/fwtool/Makefile
+++ b/package/system/fwtool/Makefile
@@ -8,15 +8,24 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fwtool
-PKG_RELEASE:=2
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=$(PROJECT_GIT)/project/fwtool.git
+PKG_SOURCE_DATE:=2019-11-09
+PKG_SOURCE_VERSION:=9d9d4c2847862adec2f474d4126213c17f98e024
+PKG_MIRROR_HASH:=4a72a48cbc7cda4c1860ec8328c049b4b84f7f00273d82ee98175937b63af1f8
+CMAKE_INSTALL:=1
PKG_FLAGS:=nonshared
+PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER := Felix Fietkau <nbd@nbd.name>
PKG_BUILD_DEPENDS := fwtool/host
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
HOST_BUILD_PREFIX:=$(STAGING_DIR_HOST)
@@ -26,21 +35,13 @@ define Package/fwtool
TITLE:=Utility for appending and extracting firmware metadata and signatures
endef
-define Host/Compile
- $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) -o $(HOST_BUILD_DIR)/fwtool ./src/fwtool.c
-endef
-
define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/fwtool $(1)/bin/
endef
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/fwtool ./src/fwtool.c
-endef
-
define Package/fwtool/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/fwtool $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fwtool $(1)/usr/bin/
endef
$(eval $(call HostBuild))