aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ca-certificates
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-07-05 18:51:54 +0800
committerJo-Philipp Wich <jo@mein.io>2018-12-18 09:43:56 +0100
commit3e02d196553ca44a17889053f7582a3ac4f2098a (patch)
treee560fa7951d3fe4ba8be7fcbd5b32380a2179e1f /package/system/ca-certificates
parent60b29c9c177d7865dd116eeb574fc9c8ab775b77 (diff)
downloadupstream-3e02d196553ca44a17889053f7582a3ac4f2098a.tar.gz
upstream-3e02d196553ca44a17889053f7582a3ac4f2098a.tar.bz2
upstream-3e02d196553ca44a17889053f7582a3ac4f2098a.zip
ca-certificates: ca-bundle: add symlink for openssl default setting
OpenSSL defaults X509_CERT_FILE to /etc/ssl/cert.pem. This change is needed for wget-ssl and possibly others to work seamlessly with fresh ca-bundle installation Fixes openwrt/packages#6152 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> (backported from 191078e83d127f5ed9a38366d2edaac49f9333c5)
Diffstat (limited to 'package/system/ca-certificates')
-rw-r--r--package/system/ca-certificates/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/system/ca-certificates/Makefile b/package/system/ca-certificates/Makefile
index 5ee7a3528c..43003cf925 100644
--- a/package/system/ca-certificates/Makefile
+++ b/package/system/ca-certificates/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ca-certificates
PKG_VERSION:=20180409
+PKG_RELEASE:=2
PKG_MAINTAINER:=
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.xz
@@ -57,6 +58,7 @@ endef
define Package/ca-bundle/install
$(INSTALL_DIR) $(1)/etc/ssl/certs
cat $(PKG_INSTALL_DIR)/usr/share/ca-certificates/*/*.crt >$(1)/etc/ssl/certs/ca-certificates.crt
+ $(LN) /etc/ssl/certs/ca-certificates.crt $(1)/etc/ssl/cert.pem
endef
$(eval $(call BuildPackage,ca-certificates))
$(eval $(call BuildPackage,ca-bundle))