aboutsummaryrefslogtreecommitdiffstats
path: root/package/switch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-04-05 13:51:26 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-04-05 13:51:26 +0000
commit501e154d03db5c52b0fc5b655651f81e74c7c0ff (patch)
treef661c27da036662aeabbb6fc8e2805e06537473e /package/switch
parent83bf10cb3f92c3e0f336c8d6434258750d7b0515 (diff)
downloadupstream-501e154d03db5c52b0fc5b655651f81e74c7c0ff.tar.gz
upstream-501e154d03db5c52b0fc5b655651f81e74c7c0ff.tar.bz2
upstream-501e154d03db5c52b0fc5b655651f81e74c7c0ff.zip
switch: explicitely clear port mappings in unsused vlans (#7082)
SVN-Revision: 20717
Diffstat (limited to 'package/switch')
-rw-r--r--package/switch/Makefile2
-rw-r--r--package/switch/files/switch.sh6
2 files changed, 7 insertions, 1 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index a9b881c40e..74e42e6d93 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=kmod-switch
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
diff --git a/package/switch/files/switch.sh b/package/switch/files/switch.sh
index f0bd8ce60f..6517ca9853 100644
--- a/package/switch/files/switch.sh
+++ b/package/switch/files/switch.sh
@@ -15,6 +15,12 @@ setup_switch_hw() {
echo "$evlan" > "$proc/enable_vlan"
[ -f "$proc/enable" ] && echo "$enable" > "$proc/enable"
}
+
+ local vlan
+ for vlan in `seq 0 15`; do
+ proc="/proc/switch/$dev/vlan/$vlan/ports"
+ [ -f "$proc" ] && echo "" > "$proc"
+ done
}
setup_switch_vlan() {