aboutsummaryrefslogtreecommitdiffstats
path: root/package/switch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commit5a325930579db5f9175bea19459c845746801ae4 (patch)
tree8b63e203323c3c4ab05aa9bf0a9ec17f5dc87c91 /package/switch
parent7bc567a0409f4d9aa9a4e12e9c56bc892b737da3 (diff)
downloadupstream-5a325930579db5f9175bea19459c845746801ae4.tar.gz
upstream-5a325930579db5f9175bea19459c845746801ae4.tar.bz2
upstream-5a325930579db5f9175bea19459c845746801ae4.zip
replace lots of manual install commands with INSTALL_* variables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/switch')
-rw-r--r--package/switch/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index 07208bc30f..a0644abeb1 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -41,12 +41,12 @@ define Build/Compile
endef
define Package/kmod-switch/install
- install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
$(1)/lib/modules/$(LINUX_VERSION)
- install -m0755 -d $(1)/lib/network/
- install -m0755 ./files/switch.sh $(1)/lib/network/
- install -m0755 -d $(1)/etc/modules.d/
+ $(INSTALL_DIR) $(1)/lib/network/
+ $(INSTALL_BIN) ./files/switch.sh $(1)/lib/network/
+ $(INSTALL_DIR) $(1)/etc/modules.d/
printf 'switch-core\nswitch-robo\nswitch-adm\n' > $(1)/etc/modules.d/20-switch
endef