aboutsummaryrefslogtreecommitdiffstats
path: root/package/switch/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:43:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:43:41 +0000
commit3bc5d6887d903c78026a7e9def67f349ca119911 (patch)
tree27936dc85f4d3dcb24795df04b6753d87810af74 /package/switch/Makefile
parent17fee1112f0f8760b12c1959cff3a2dc8c1aaa68 (diff)
downloadupstream-3bc5d6887d903c78026a7e9def67f349ca119911.tar.gz
upstream-3bc5d6887d903c78026a7e9def67f349ca119911.tar.bz2
upstream-3bc5d6887d903c78026a7e9def67f349ca119911.zip
remove linux 2.4 support from several packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21954 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/switch/Makefile')
-rw-r--r--package/switch/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index 74e42e6d93..7570f56d3d 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -15,7 +15,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/switch
SUBMENU:=Other modules
- DEPENDS:=@TARGET_brcm_2_4||TARGET_brcm47xx||TARGET_brcm63xx
+ DEPENDS:=@TARGET_brcm47xx||TARGET_brcm63xx
TITLE:=Switch drivers
FILES:= \
$(PKG_BUILD_DIR)/switch-core.$(LINUX_KMOD_SUFFIX) \
@@ -33,15 +33,10 @@ define Build/Prepare
$(CP) ./src/* $(PKG_BUILD_DIR)/
endef
-ifeq ($(BOARD),brcm-2.4)
- BUILDFLAGS := -DBROADCOM -DBCMDRIVER -I$(LINUX_DIR)/arch/mips/bcm947xx/include
-else
- ifeq ($(BOARD),brcm47xx)
+ifeq ($(BOARD),brcm47xx)
BUILDFLAGS := -DBROADCOM
- endif
endif
-
define Build/Compile
$(MAKE) -C "$(LINUX_DIR)" \
CROSS_COMPILE="$(TARGET_CROSS)" \