aboutsummaryrefslogtreecommitdiffstats
path: root/package/swconfig
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-16 14:23:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-16 14:23:01 +0000
commitcf15b9d70940e3e38ea6714af029b719c63a1894 (patch)
treecd6f4244d5230b58dcf13d5d4505a86eab5b6abd /package/swconfig
parent7c738992b16f17ddf1262a5555ee42a44618e762 (diff)
downloadupstream-cf15b9d70940e3e38ea6714af029b719c63a1894.tar.gz
upstream-cf15b9d70940e3e38ea6714af029b719c63a1894.tar.bz2
upstream-cf15b9d70940e3e38ea6714af029b719c63a1894.zip
[package] swconfig: clear ip address on the switch interface, this prevents duplicate assignments of 192.168.1.1 on the DIR-300 at least
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/swconfig')
-rw-r--r--package/swconfig/Makefile2
-rw-r--r--package/swconfig/files/switch.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/swconfig/Makefile b/package/swconfig/Makefile
index a3844c5f63..bec94a1ca0 100644
--- a/package/swconfig/Makefile
+++ b/package/swconfig/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=swconfig
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk
diff --git a/package/swconfig/files/switch.sh b/package/swconfig/files/switch.sh
index d752b1383d..7078b2e823 100644
--- a/package/swconfig/files/switch.sh
+++ b/package/swconfig/files/switch.sh
@@ -2,6 +2,7 @@
# Copyright (C) 2009 OpenWrt.org
setup_switch_dev() {
+ ifconfig "$1" 0.0.0.0
swconfig dev "$1" load network
}