aboutsummaryrefslogtreecommitdiffstats
path: root/package/swconfig
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-28 19:54:11 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-28 19:54:11 +0000
commit892b77ebe16a053f6266fa79fa2e514214b37341 (patch)
treeeba99a4358f2b0ad76f5187b4f60be74be7f7d8f /package/swconfig
parent3649909c09cc8b7009f53f649dba4fa87647b0a2 (diff)
downloadupstream-892b77ebe16a053f6266fa79fa2e514214b37341.tar.gz
upstream-892b77ebe16a053f6266fa79fa2e514214b37341.tar.bz2
upstream-892b77ebe16a053f6266fa79fa2e514214b37341.zip
swconfig: fix backward compatibility
swconfig fails to load uci configuration after the generic switch identifier changes. root@OpenWrt:/# uci show network | grep switch network.@switch[0]=switch network.@switch[0].name=eth0 network.@switch[0].reset=1 network.@switch[0].enable_vlan=1 network.@switch_vlan[0]=switch_vlan network.@switch_vlan[0].device=eth0 network.@switch_vlan[0].vlan=1 network.@switch_vlan[0].ports=0t 2 3 4 5 network.@switch_vlan[1]=switch_vlan network.@switch_vlan[1].device=eth0 network.@switch_vlan[1].vlan=2 network.@switch_vlan[1].ports=0t 1 root@OpenWrt:/# swconfig dev eth0 load /etc/config/network Failed to apply configuration for switch 'switch0' root@OpenWrt:/# swconfig dev switch0 load /etc/config/network Failed to apply configuration for switch 'switch0' git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27820 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/swconfig')
-rw-r--r--package/swconfig/Makefile2
-rw-r--r--package/swconfig/src/uci.c14
2 files changed, 11 insertions, 5 deletions
diff --git a/package/swconfig/Makefile b/package/swconfig/Makefile
index 58ae75f466..91939bb73f 100644
--- a/package/swconfig/Makefile
+++ b/package/swconfig/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=swconfig
-PKG_RELEASE:=8
+PKG_RELEASE:=9
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk
diff --git a/package/swconfig/src/uci.c b/package/swconfig/src/uci.c
index ce544c3d58..1de689ce6e 100644
--- a/package/swconfig/src/uci.c
+++ b/package/swconfig/src/uci.c
@@ -53,6 +53,12 @@ struct swlib_setting early_settings[] = {
static struct swlib_setting *settings;
static struct swlib_setting **head;
+static bool swlib_match_name(struct switch_dev *dev, const char *name)
+{
+ return (strcmp(name, dev->dev_name) == 0 ||
+ strcmp(name, dev->alias) == 0);
+}
+
static int
swlib_map_settings(struct switch_dev *dev, int type, int port_vlan, struct uci_section *s)
{
@@ -131,13 +137,13 @@ int swlib_apply_from_uci(struct switch_dev *dev, struct uci_package *p)
if (o->type != UCI_TYPE_STRING)
continue;
- if (!strcmp(o->v.string, dev->dev_name))
+ if (swlib_match_name(dev, o->v.string))
goto found;
break;
}
- if (strcmp(e->name, dev->dev_name) != 0)
+ if (!swlib_match_name(dev, e->name))
continue;
goto found;
@@ -171,7 +177,7 @@ found:
if (!strcmp(os->name, "device")) {
devn = o->v.string;
- if (strcmp(devn, dev->dev_name) != 0)
+ if (!swlib_match_name(dev, devn))
devn = NULL;
} else if (!strcmp(os->name, "port")) {
port = o->v.string;
@@ -196,7 +202,7 @@ found:
if (!strcmp(os->name, "device")) {
devn = o->v.string;
- if (strcmp(devn, dev->dev_name) != 0)
+ if (!swlib_match_name(dev, devn))
devn = NULL;
} else if (!strcmp(os->name, "vlan")) {
vlan = o->v.string;