aboutsummaryrefslogtreecommitdiffstats
path: root/package/swconfig/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 20:44:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 20:44:53 +0000
commitdabd596e39c58eddc0f2361d12f415d5482307aa (patch)
treefad159c87916c32379b95fedc3dadd6e7c901537 /package/swconfig/src/Makefile
parent6d784c2ba279e363a42e34ce1f2926170cfb71d0 (diff)
downloadupstream-dabd596e39c58eddc0f2361d12f415d5482307aa.tar.gz
upstream-dabd596e39c58eddc0f2361d12f415d5482307aa.tar.bz2
upstream-dabd596e39c58eddc0f2361d12f415d5482307aa.zip
add new switch configuration api
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13009 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/swconfig/src/Makefile')
-rw-r--r--package/swconfig/src/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/swconfig/src/Makefile b/package/swconfig/src/Makefile
new file mode 100644
index 0000000000..64816af541
--- /dev/null
+++ b/package/swconfig/src/Makefile
@@ -0,0 +1,12 @@
+ifndef CFLAGS
+CFLAGS = -O2 -g -I ../src
+endif
+LIBS=-lnl
+
+all: swconfig
+
+%.o: %.c
+ $(CC) $(CFLAGS) -c -o $@ $^
+
+swconfig: cli.o swlib.o
+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)