aboutsummaryrefslogtreecommitdiffstats
path: root/package/soloscli
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-06-02 14:38:01 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-06-02 14:38:01 +0000
commit90f0d47a03d02e6b19d24b6a745fe30de1e03418 (patch)
tree9f3c1011629d2b75d3299dde2e74c2c7ba41925d /package/soloscli
parent7d8d47d29e5d001bb43c6a7c0b0fecc4ccabddb2 (diff)
downloadupstream-90f0d47a03d02e6b19d24b6a745fe30de1e03418.tar.gz
upstream-90f0d47a03d02e6b19d24b6a745fe30de1e03418.tar.bz2
upstream-90f0d47a03d02e6b19d24b6a745fe30de1e03418.zip
soloscli: fix new lines in soloscli
If the string received from the ADSL firmware is missing \n, add it in. Signed-off-by: Nathan Williams <nathan@traverse.com.au> SVN-Revision: 27096
Diffstat (limited to 'package/soloscli')
-rw-r--r--package/soloscli/Makefile4
-rw-r--r--package/soloscli/patches/001-newline.patch8
2 files changed, 8 insertions, 4 deletions
diff --git a/package/soloscli/Makefile b/package/soloscli/Makefile
index 1c2d998090..490186dbec 100644
--- a/package/soloscli/Makefile
+++ b/package/soloscli/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=soloscli
PKG_VERSION:=0.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/openadsl
diff --git a/package/soloscli/patches/001-newline.patch b/package/soloscli/patches/001-newline.patch
index 69cd5b28a6..4b663e8898 100644
--- a/package/soloscli/patches/001-newline.patch
+++ b/package/soloscli/patches/001-newline.patch
@@ -1,11 +1,15 @@
--- a/soloscli/soloscli.c
+++ b/soloscli/soloscli.c
-@@ -238,7 +238,7 @@
+@@ -238,7 +238,11 @@
}
if (strcmp(buf,pid) == 0) {
/* printf("Sequence matches.\n"); */
- printf("%s",bufp);
-+ printf("%s\n",bufp);
++ if(buf[(len-1)] == '\n'){
++ printf("%s",bufp);
++ } else {
++ printf("%s\n",bufp);
++ }
} else {
printf("Sequence incorrect.\n");
buf[i] = '\n';