aboutsummaryrefslogtreecommitdiffstats
path: root/package/soloscli
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-06-02 14:38:01 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-06-02 14:38:01 +0000
commit8dc323870c81628ca4a9c5fb31d8b4a867468cbe (patch)
tree4212c6401db42a1ff8cbd3c2d4cd6e42989d1074 /package/soloscli
parent54e9324ca37ec0fbc6875a2b2826019712c76f56 (diff)
downloadupstream-8dc323870c81628ca4a9c5fb31d8b4a867468cbe.tar.gz
upstream-8dc323870c81628ca4a9c5fb31d8b4a867468cbe.tar.bz2
upstream-8dc323870c81628ca4a9c5fb31d8b4a867468cbe.zip
[package] soloscli: fix new lines in soloscli
If the string received from the ADSL firmware is missing \n, add it in. Signed-off-by: Nathan Williams <nathan@traverse.com.au> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27096 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/soloscli')
-rw-r--r--package/soloscli/Makefile4
-rw-r--r--package/soloscli/patches/001-newline.patch8
2 files changed, 8 insertions, 4 deletions
diff --git a/package/soloscli/Makefile b/package/soloscli/Makefile
index 1c2d998090..490186dbec 100644
--- a/package/soloscli/Makefile
+++ b/package/soloscli/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=soloscli
PKG_VERSION:=0.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/openadsl
diff --git a/package/soloscli/patches/001-newline.patch b/package/soloscli/patches/001-newline.patch
index 69cd5b28a6..4b663e8898 100644
--- a/package/soloscli/patches/001-newline.patch
+++ b/package/soloscli/patches/001-newline.patch
@@ -1,11 +1,15 @@
--- a/soloscli/soloscli.c
+++ b/soloscli/soloscli.c
-@@ -238,7 +238,7 @@
+@@ -238,7 +238,11 @@
}
if (strcmp(buf,pid) == 0) {
/* printf("Sequence matches.\n"); */
- printf("%s",bufp);
-+ printf("%s\n",bufp);
++ if(buf[(len-1)] == '\n'){
++ printf("%s",bufp);
++ } else {
++ printf("%s\n",bufp);
++ }
} else {
printf("Sequence incorrect.\n");
buf[i] = '\n';