aboutsummaryrefslogtreecommitdiffstats
path: root/package/shfs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
commit1c4a2a55f76e481a2d1bc005405b9ce856d58939 (patch)
tree80dfa6ecb493ee8cb9ca1436f1b37ee89f320a55 /package/shfs
parentfdd5681c06468a606180f04c2533c8ba213a37f6 (diff)
downloadupstream-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.gz
upstream-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.bz2
upstream-1c4a2a55f76e481a2d1bc005405b9ce856d58939.zip
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/shfs')
-rw-r--r--package/shfs/Config.in30
-rw-r--r--package/shfs/Makefile8
-rw-r--r--package/shfs/ipkg/kmod-shfs.control8
3 files changed, 2 insertions, 44 deletions
diff --git a/package/shfs/Config.in b/package/shfs/Config.in
index 5db9308f2a..a464a4137e 100644
--- a/package/shfs/Config.in
+++ b/package/shfs/Config.in
@@ -1,37 +1,11 @@
config BR2_PACKAGE_SHFS
bool
default n
- depends BR2_PACKAGE_KMOD_SHFS
+ depends BR2_PACKAGE_SHFS_UTILS
-config BR2_PACKAGE_KMOD_SHFS
- prompt "kmod-shfs - Shell FileSystem kernel module (ShFS) kernel module"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_SHFS
- help
- ShFS is a simple and easy to use Linux kernel module which
- allows you to mount remote filesystems using a plain shell
- (SSH) connection. When using ShFS, you can access all remote
- files just like the local ones, only the access is governed
- through the transport security of SSH.
-
- ShFS supports some nice features:
-
- * file cache for access speedup
- * perl and shell code for the remote (server) side
- * could preserve uid/gid (root connection)
- * number of remote host platforms (Linux, Solaris, Cygwin, ...)
- * Linux kernel 2.4.10+ and 2.6
- * arbitrary command used for connection (instead of SSH)
- * persistent connection (reconnect after SSH dies)
-
- http://shfs.sourceforge.net/
-
- This package contains the shfs.o kernel module.
-
config BR2_PACKAGE_SHFS_UTILS
- depends BR2_PACKAGE_KMOD_SHFS
+ select BR2_PACKAGE_KMOD_SHFS
prompt "shfs-utils - ShFS mount/umount utilities"
tristate
default m if CONFIG_DEVEL
diff --git a/package/shfs/Makefile b/package/shfs/Makefile
index 32799085e0..653bc1c4fd 100644
--- a/package/shfs/Makefile
+++ b/package/shfs/Makefile
@@ -16,7 +16,6 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,KMOD_SHFS,kmod-shfs,$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,SHFS_UTILS,shfs-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
@@ -35,13 +34,6 @@ $(PKG_BUILD_DIR)/.built:
all install
touch $@
-$(IPKG_KMOD_SHFS):
- install -m0755 -d $(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)
- cp -fpR $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.o \
- $(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)/
- $(RSTRIP_KMOD) $(IDIR_KMOD_SHFS)
- $(IPKG_BUILD) $(IDIR_KMOD_SHFS) $(PACKAGE_DIR)
-
$(IPKG_SHFS_UTILS):
install -m0755 -d $(IDIR_SHFS_UTILS)/usr/sbin
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/shfs{,u}mount $(IDIR_SHFS_UTILS)/usr/sbin/
diff --git a/package/shfs/ipkg/kmod-shfs.control b/package/shfs/ipkg/kmod-shfs.control
deleted file mode 100644
index b7ce612933..0000000000
--- a/package/shfs/ipkg/kmod-shfs.control
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: kmod-shfs
-Priority: optional
-Section: net
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/shfs/
-Description: SHell FileSystem Linux kernel module