aboutsummaryrefslogtreecommitdiffstats
path: root/package/shfs
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
commit2180fa92a1158fe8f660b3a69a8f9848309ce9b6 (patch)
tree0f9b6c1a366e3cdca242f1fbebe68337d21e3b7b /package/shfs
parentf2b24749083122a565ebf96a9143cb763d17345e (diff)
downloadupstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.gz
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.bz2
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.zip
move package description to a separate definition, remove it when DESCRIPTION=TITLE
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8659 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/shfs')
-rw-r--r--package/shfs/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/package/shfs/Makefile b/package/shfs/Makefile
index 086a538319..a5ee79b05e 100644
--- a/package/shfs/Makefile
+++ b/package/shfs/Makefile
@@ -21,34 +21,40 @@ include $(INCLUDE_DIR)/package.mk
define Package/shfs/Default
TITLE:=ShFS
- DESCRIPTION:=\
- ShFS is a simple and easy to use Linux kernel module which allows you to \\\
- mount remote filesystems using a plain shell (SSH) connection. When using \\\
- ShFS, you can access all remote files just like the local ones, only the \\\
- access is governed through the transport security of SSH.
URL:=http://shfs.sourceforge.net/
endef
+define Package/shfs/Default/description
+ ShFS is a simple and easy to use Linux kernel module which allows you to
+ mount remote filesystems using a plain shell (SSH) connection. When using
+ ShFS, you can access all remote files just like the local ones, only the
+ access is governed through the transport security of SSH.
+endef
+
define KernelPackage/shfs
- $(call Package/shfs/Default)
+$(call Package/shfs/Default)
TITLE+= (kernel module)
- DESCRIPTION+=\\\
- \\\
- This package contains the ShFS kernel module.
FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
SUBMENU:=Filesystems
AUTOLOAD:=$(call AutoLoad,40,shfs)
endef
+define KernelPackage/shfs/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS kernel module.
+endef
+
define Package/shfs-utils
- $(call Package/shfs/Default)
+$(call Package/shfs/Default)
SECTION:=utils
CATEGORY:=Utilities
DEPENDS+=+kmod-shfs
TITLE+= (utilities)
- DESCRIPTION+=\\\
- \\\
- This package contains the ShFS utilities.
+endef
+
+define Package/shfs-utils/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS utilities.
endef
define Build/Compile