aboutsummaryrefslogtreecommitdiffstats
path: root/package/rt61/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-01-07 23:29:43 +0000
committerNicolas Thill <nico@openwrt.org>2007-01-07 23:29:43 +0000
commit6999dd0f420346868c4c33424b826f634ba3d8bc (patch)
tree6fed66d6ffeab853feeb5e941c4eade2820ab456 /package/rt61/Makefile
parent040e09343961c2b44d617bf6c5094cb5b902624f (diff)
downloadupstream-6999dd0f420346868c4c33424b826f634ba3d8bc.tar.gz
upstream-6999dd0f420346868c4c33424b826f634ba3d8bc.tar.bz2
upstream-6999dd0f420346868c4c33424b826f634ba3d8bc.zip
fix rt61 build on 2.4
SVN-Revision: 6022
Diffstat (limited to 'package/rt61/Makefile')
-rw-r--r--package/rt61/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/rt61/Makefile b/package/rt61/Makefile
index d685119b6b..0656cf4c43 100644
--- a/package/rt61/Makefile
+++ b/package/rt61/Makefile
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/rt61
SUBMENU:=Wireless Drivers
TITLE:=Driver for ralink MiMo pci chipsets
- DEPENDS:=@LINUX_2_4 @USB_SUPPORT +wireless-tools
+ DEPENDS:=@LINUX_2_4 @PCI_SUPPORT +wireless-tools
DESCRIPTION:=\
This package contains a driver for ralink rt61xx pci chipsets.
URL:=http://rt2x00.serialmonkey.com/
@@ -34,11 +34,13 @@ define KernelPackage/rt61
AUTOLOAD:=$(call AutoLoad,50,rt61)
endef
+LINUX_PATCHLEVEL:=$(shell echo "$(LINUX_VERSION)" | cut -d. -f2)
+
define Build/Compile
$(MAKE) -C $(LINUX_DIR) \
ARCH="$(LINUX_KARCH)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- PATCHLEVEL="$(LINUX_VERSION)" \
+ PATCHLEVEL="$(LINUX_PATCHLEVEL)" \
KERNDIR="$(LINUX_DIR)" \
SUBDIRS="$(PKG_BUILD_DIR)/Module" \
modules