aboutsummaryrefslogtreecommitdiffstats
path: root/package/rt2x00/src/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-30 15:38:15 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-30 15:38:15 +0000
commit917780b301ce52c4f1e2b6143e92069d78f84a5e (patch)
treeea756ddafca1b3b0522a63b15d9a36155ec991a9 /package/rt2x00/src/Makefile
parent437ad838dde0be1e7f6fd14074048f73813118e6 (diff)
downloadupstream-917780b301ce52c4f1e2b6143e92069d78f84a5e.tar.gz
upstream-917780b301ce52c4f1e2b6143e92069d78f84a5e.tar.bz2
upstream-917780b301ce52c4f1e2b6143e92069d78f84a5e.zip
rt2x00 fixes (thanks to sn9): * make build depends on in-kernel mac80211 support * rework kconfig handling * download firmware images into $(DL_DIR) * tweak source Makefile
SVN-Revision: 8548
Diffstat (limited to 'package/rt2x00/src/Makefile')
-rw-r--r--package/rt2x00/src/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/package/rt2x00/src/Makefile b/package/rt2x00/src/Makefile
index 84352c3963..dd32cf6a20 100644
--- a/package/rt2x00/src/Makefile
+++ b/package/rt2x00/src/Makefile
@@ -39,24 +39,27 @@ else
endif
#
-# Include kernel and rt2x00 config.
-#
-include $(KERNEL_SOURCES)/.config
-include $(SUBDIRS)/config
-
-#
# Determine if and with what options the rt2x00 drivers should be build
#
rt2x00lib-objs := rt2x00dev.o rt2x00mac.o
ifeq ($(CONFIG_RT2X00),y)
+ obj-m += rt2x00lib.o
+
+ifneq ($(CONFIG_PCI),)
+ obj-m += rt2x00pci.o
+endif
+
+ifneq ($(CONFIG_USB),)
+ obj-m += rt2x00usb.o
+endif
ifeq ($(CONFIG_RT2X00_LIB_DEBUGFS),y)
rt2x00lib-objs += rt2x00debug.o
endif
ifeq ($(CONFIG_RT2400PCI),y)
- obj-m += rt2400pci.o rt2x00pci.o rt2x00lib.o
+ obj-m += rt2400pci.o
ifeq ($(CONFIG_RT2400PCI_RFKILL),y)
rt2x00lib-objs += rt2x00rfkill.o
CFLAGS += -DCONFIG_RT2X00_LIB_RFKILL
@@ -64,7 +67,7 @@ endif
endif
ifeq ($(CONFIG_RT2500PCI),y)
- obj-m += rt2500pci.o rt2x00pci.o rt2x00lib.o
+ obj-m += rt2500pci.o
ifeq ($(CONFIG_RT2500PCI_RFKILL),y)
rt2x00lib-objs += rt2x00rfkill.o
CFLAGS += -DCONFIG_RT2X00_LIB_RFKILL
@@ -72,13 +75,13 @@ endif
endif
ifeq ($(CONFIG_RT2500USB),y)
- obj-m += rt2500usb.o rt2x00usb.o rt2x00lib.o
+ obj-m += rt2500usb.o
endif
ifeq ($(CONFIG_RT61PCI),y)
CFLAGS += -DCONFIG_RT2X00_LIB_FIRMWARE
rt2x00lib-objs += rt2x00firmware.o
- obj-m += rt61pci.o rt2x00pci.o rt2x00lib.o
+ obj-m += rt61pci.o
ifeq ($(CONFIG_RT61PCI_RFKILL),y)
rt2x00lib-objs += rt2x00rfkill.o
CFLAGS += -DCONFIG_RT2X00_LIB_RFKILL
@@ -88,13 +91,12 @@ endif
ifeq ($(CONFIG_RT73USB),y)
CFLAGS += -DCONFIG_RT2X00_LIB_FIRMWARE
rt2x00lib-objs += rt2x00firmware.o
- obj-m += rt73usb.o rt2x00usb.o rt2x00lib.o
+ obj-m += rt73usb.o
endif
endif
MAKEFLAGS += --no-print-directory
-CFLAGS := -include $(SUBDIRS)/rt2x00_compat.h $(CFLAGS)
all: default