aboutsummaryrefslogtreecommitdiffstats
path: root/package/rt2500
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-09-26 09:42:17 +0000
committerNicolas Thill <nico@openwrt.org>2008-09-26 09:42:17 +0000
commit32e625fc9e355a3546829eed9b39d00cc9874b7d (patch)
tree8c214a1437b91f673aaa7ba62492e8767db8f808 /package/rt2500
parent57481bf0207d5b6033a6fbe883356129ba3adc42 (diff)
downloadupstream-32e625fc9e355a3546829eed9b39d00cc9874b7d.tar.gz
upstream-32e625fc9e355a3546829eed9b39d00cc9874b7d.tar.bz2
upstream-32e625fc9e355a3546829eed9b39d00cc9874b7d.zip
remove obsolete p54, rt2500 & rt61 since those drivers are built from package/mac80211 now
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12716 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/rt2500')
-rw-r--r--package/rt2500/Makefile45
-rw-r--r--package/rt2500/patches/001-rt2561t.patch22
2 files changed, 0 insertions, 67 deletions
diff --git a/package/rt2500/Makefile b/package/rt2500/Makefile
deleted file mode 100644
index 0b3e0136a7..0000000000
--- a/package/rt2500/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=rt2500
-PKG_VERSION:=cvs-2007061115
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=67a158b24ec46e37edc4545f51338bb9
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/rt2500
- SUBMENU:=Wireless Drivers
- TITLE:=Driver for Ralink RT2500 pci wireless chipsets
- DEPENDS:=@!LINUX_2_6_24&&!LINUX_2_6_25 @!BIG_ENDIAN @USB_SUPPORT +wireless-tools
- URL:=http://rt2x00.serialmonkey.com/
- FILES:=$(PKG_BUILD_DIR)/Module/rt2500.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,50,rt2500)
-endef
-
-define KernelPackage/rt2500/description
- This package contains a driver for Ralink RT2500 pci chipsets.
-endef
-
-define Build/Compile
- $(MAKE) -C "$(PKG_BUILD_DIR)/Module" \
- CC="$(TARGET_CC)" \
- LD="$(TARGET_CROSS)ld" \
- ARCH="$(LINUX_KARCH)" \
- PWD="$(PKG_BUILD_DIR)/Module" \
- KERNDIR="$(LINUX_DIR)" \
- PATCHLEVEL="$(patsubst 2.%,%,$(KERNEL))"
-endef
-
-$(eval $(call KernelPackage,rt2500))
diff --git a/package/rt2500/patches/001-rt2561t.patch b/package/rt2500/patches/001-rt2561t.patch
deleted file mode 100644
index 5b83432580..0000000000
--- a/package/rt2500/patches/001-rt2561t.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -urN rt2500-cvs-2007061115.new/Module/rt_config.h rt2500-cvs-2007061115/Module/rt_config.h
---- rt2500-cvs-2007061115.new/Module/rt_config.h 2007-06-11 22:35:28.000000000 +0200
-+++ rt2500-cvs-2007061115/Module/rt_config.h 2007-06-11 22:57:31.000000000 +0200
-@@ -153,6 +153,7 @@
-
- enum rt2560_chips {
- RT2560A = 0,
-+ RT2561T = 0,
- };
-
- #if 1 //#ifdef RTMP_EMBEDDED
-diff -urN rt2500-cvs-2007061115.new/Module/rtmp_main.c rt2500-cvs-2007061115/Module/rtmp_main.c
---- rt2500-cvs-2007061115.new/Module/rtmp_main.c 2007-05-29 05:49:17.000000000 +0200
-+++ rt2500-cvs-2007061115/Module/rtmp_main.c 2007-06-11 22:57:13.000000000 +0200
-@@ -1041,6 +1041,7 @@
- static struct pci_device_id rt2500_pci_tbl[] __devinitdata =
- {
- {0x1814, 0x0201, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RT2560A},
-+ {0x1814, 0x0301, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RT2561T},
- {0,} /* terminate list */
- };
- MODULE_DEVICE_TABLE(pci, rt2500_pci_tbl);