aboutsummaryrefslogtreecommitdiffstats
path: root/package/rt2500/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
commit2180fa92a1158fe8f660b3a69a8f9848309ce9b6 (patch)
tree0f9b6c1a366e3cdca242f1fbebe68337d21e3b7b /package/rt2500/Makefile
parentf2b24749083122a565ebf96a9143cb763d17345e (diff)
downloadupstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.gz
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.bz2
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.zip
move package description to a separate definition, remove it when DESCRIPTION=TITLE
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8659 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/rt2500/Makefile')
-rw-r--r--package/rt2500/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/package/rt2500/Makefile b/package/rt2500/Makefile
index cd38c25167..e6cb9d51b4 100644
--- a/package/rt2500/Makefile
+++ b/package/rt2500/Makefile
@@ -21,16 +21,17 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/rt2500
SUBMENU:=Wireless Drivers
- TITLE:=Driver for ralink pci wireless chipsets
+ TITLE:=Driver for Ralink RT2500 pci wireless chipsets
DEPENDS:=@!BIG_ENDIAN @USB_SUPPORT +wireless-tools
- DESCRIPTION:=\
- This package contains a driver for ralink rt2500 pci chipsets.
URL:=http://rt2x00.serialmonkey.com/
- FILES:= \
- $(PKG_BUILD_DIR)/Module/rt2500.$(LINUX_KMOD_SUFFIX)
+ FILES:=$(PKG_BUILD_DIR)/Module/rt2500.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,50,rt2500)
endef
+define KernelPackage/rt2500/description
+ This package contains a driver for Ralink RT2500 pci chipsets.
+endef
+
define Build/Compile
$(MAKE) -C "$(PKG_BUILD_DIR)/Module" \
CC="$(TARGET_CC)" \