aboutsummaryrefslogtreecommitdiffstats
path: root/package/resolveip/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-17 22:20:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-17 22:20:48 +0000
commit28505cad0dd7be04aa706eda0a4bdae20d286788 (patch)
treeff5e58336b3e73b003abb31c14b82d61969e8c1a /package/resolveip/Makefile
parent59063773328e02631c611efc34cf574c0abbeb42 (diff)
downloadupstream-28505cad0dd7be04aa706eda0a4bdae20d286788.tar.gz
upstream-28505cad0dd7be04aa706eda0a4bdae20d286788.tar.bz2
upstream-28505cad0dd7be04aa706eda0a4bdae20d286788.zip
add "resolveip", a small DNS lookup utility for use in scripts (#4876)
SVN-Revision: 27666
Diffstat (limited to 'package/resolveip/Makefile')
-rw-r--r--package/resolveip/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/resolveip/Makefile b/package/resolveip/Makefile
new file mode 100644
index 0000000000..6ab04e162e
--- /dev/null
+++ b/package/resolveip/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=resolveip
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/resolveip
+ SECTION:=utils
+ CATEGORY:=Base system
+ TITLE:=Simple DNS resolver with configurable timeout
+endef
+
+define Package/resolveip/description
+ This package contains the small resolveip utility which
+ can be used by scripts to turn host names into numeric
+ IP addresses. It supports IPv4 and IPv6 resolving and
+ has a configurable timeout to guarantee a certain maximum
+ runtime in case of slow or defunct DNS servers.
+endef
+
+define Build/Prepare
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)
+ $(INSTALL_DATA) ./src/resolveip.c $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(TARGET_CC) $(TARGET_CFLAGS) -Wall \
+ -o $(PKG_BUILD_DIR)/resolveip $(PKG_BUILD_DIR)/resolveip.c
+endef
+
+define Package/resolveip/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/resolveip $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,resolveip))