aboutsummaryrefslogtreecommitdiffstats
path: root/package/qos-scripts/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-04-12 20:33:11 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-04-12 20:33:11 +0000
commitd136e7f6934bbe1081b68a219aeb04f4a6b7c33b (patch)
treeb7a173752141524767a4014dc7bbd07626526b3c /package/qos-scripts/Makefile
parent5cf0e4f471ff68d08118a8854b398725d4a28e74 (diff)
downloadupstream-d136e7f6934bbe1081b68a219aeb04f4a6b7c33b.tar.gz
upstream-d136e7f6934bbe1081b68a219aeb04f4a6b7c33b.tar.bz2
upstream-d136e7f6934bbe1081b68a219aeb04f4a6b7c33b.zip
This patch updates qos-scripts to support fair traffic sharing using the
SFQ with external classifiers method. It also corrects a bug in the unsupported ESFQ method already used by qos-scripts. (ESFQ: http://fatooh.org/esfq-2.6/ only updated to 2.6.24, it was switched to an SFQ patch after that and not updated since 2008) A class can be forced to use SFQ, and an external classifier added like this: config class "Normal" option avgrate 10 option priority 30 option packetdelay 100 option limitrate 94 # option qdisc "sfq perturb 2" config class "Normal_up" # option filter "protocol all flow hash keys src divisor 1024" config class "Normal_down" # option filter "protocol all flow hash keys dst divisor 1024" Using these options, the user needs to load cls_flow before qos-scripts starts. I've got more information here: http://oneitguy.com/blogs/netprince/fair-traffic-sharing-esfq-broken-switching-sfqexternal-classifiers This has been tested on r23914. Signed-off-by: Ben Pfountz <netprince<>vt_edu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26622 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/qos-scripts/Makefile')
-rw-r--r--package/qos-scripts/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/qos-scripts/Makefile b/package/qos-scripts/Makefile
index 21607a2d74..d76dbba854 100644
--- a/package/qos-scripts/Makefile
+++ b/package/qos-scripts/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=qos-scripts
PKG_VERSION:=1.2.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)