aboutsummaryrefslogtreecommitdiffstats
path: root/package/qos-scripts/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-06 17:38:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-06 17:38:48 +0000
commit19b00416ab85605ef56cc2123aabfba8049992c6 (patch)
treec9fe5a99c04535a971d100549cad164553a01c2c /package/qos-scripts/Makefile
parenta2aa7e5779e09f4399d4e5bc2d51d982bc117a91 (diff)
downloadupstream-19b00416ab85605ef56cc2123aabfba8049992c6.tar.gz
upstream-19b00416ab85605ef56cc2123aabfba8049992c6.tar.bz2
upstream-19b00416ab85605ef56cc2123aabfba8049992c6.zip
add qos-scripts package port for buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4935 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/qos-scripts/Makefile')
-rw-r--r--package/qos-scripts/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/qos-scripts/Makefile b/package/qos-scripts/Makefile
new file mode 100644
index 0000000000..444009791c
--- /dev/null
+++ b/package/qos-scripts/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 4823 2006-09-23 13:45:49Z nico $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=qos-scripts
+PKG_VERSION:=0.9.2
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/qos-scripts
+ SECTION:=utils
+ CATEGORY:=Base system
+ DEPENDS:=+tc +kmod-sched +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-extra +iptables-mod-conntrack +iptables-mod-imq
+ TITLE:=QoS scripts
+ DESCRIPTION:=QoS scripts \\\
+ A set of scripts that abstract QoS configuration \\\
+ into a simple configuration file supporting stanzas that specify \\\
+ any number of QoS entries.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/qos-scripts/install
+ mkdir -p $(1)
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,qos-scripts))