aboutsummaryrefslogtreecommitdiffstats
path: root/package/px5g/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-25 15:46:39 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-25 15:46:39 +0000
commit960a327a19e605f16bc5778d1e551eeba65f4680 (patch)
tree040e278b00ff66581e0db568d2ed3f8da2aaf777 /package/px5g/src/Makefile
parent4ebe5e79c6d2c55877f9abf04e63ca9a9b1b7bd6 (diff)
downloadupstream-960a327a19e605f16bc5778d1e551eeba65f4680.tar.gz
upstream-960a327a19e605f16bc5778d1e551eeba65f4680.tar.bz2
upstream-960a327a19e605f16bc5778d1e551eeba65f4680.zip
[package] add px5g (moved from LuCI trunk)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20429 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/px5g/src/Makefile')
-rw-r--r--package/px5g/src/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/px5g/src/Makefile b/package/px5g/src/Makefile
new file mode 100644
index 0000000000..2bd95739cb
--- /dev/null
+++ b/package/px5g/src/Makefile
@@ -0,0 +1,14 @@
+CFLAGS?=-O2
+CFLAGS+=
+SFLAGS:=--std=gnu99
+WFLAGS:=-Wall -Werror -pedantic
+LDFLAGS?=
+BINARY:=px5g
+
+all: $(BINARY)
+
+$(BINARY): *.c library/*.c
+ $(CC) -I. $(CFLAGS) $(SFLAGS) $(WFLAGS) $(LDFLAGS) -o $@ $+
+
+clean:
+ rm -f $(BINARY)