aboutsummaryrefslogtreecommitdiffstats
path: root/package/px5g/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-25 15:46:39 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-25 15:46:39 +0000
commit960a327a19e605f16bc5778d1e551eeba65f4680 (patch)
tree040e278b00ff66581e0db568d2ed3f8da2aaf777 /package/px5g/Makefile
parent4ebe5e79c6d2c55877f9abf04e63ca9a9b1b7bd6 (diff)
downloadupstream-960a327a19e605f16bc5778d1e551eeba65f4680.tar.gz
upstream-960a327a19e605f16bc5778d1e551eeba65f4680.tar.bz2
upstream-960a327a19e605f16bc5778d1e551eeba65f4680.zip
[package] add px5g (moved from LuCI trunk)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20429 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/px5g/Makefile')
-rw-r--r--package/px5g/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/px5g/Makefile b/package/px5g/Makefile
new file mode 100644
index 0000000000..638f8c0c4e
--- /dev/null
+++ b/package/px5g/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=px5g
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/px5g
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Standalone X.509 certificate generator
+endef
+
+define Package/px5g/description
+ Px5g is a tiny standalone X.509 certificate generator.
+ It suitable to create key files and certificates in DER
+ and PEM format for use with stunnel, uhttpd and others.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/px5g/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
+endef
+
+$(eval $(call BuildPackage,px5g))