aboutsummaryrefslogtreecommitdiffstats
path: root/package/pwm-gpio-custom/Makefile
diff options
context:
space:
mode:
authorClaudio Mignanti <c.mignanti@gmail.com>2010-07-22 11:32:33 +0000
committerClaudio Mignanti <c.mignanti@gmail.com>2010-07-22 11:32:33 +0000
commitc65d6372b537a9d870308e3375c17ff96dad488e (patch)
tree541d1f959de902231deb45e543298419b75bbefe /package/pwm-gpio-custom/Makefile
parent7b24e3fe8d538446d28adf0b405bf0c8956970ae (diff)
downloadupstream-c65d6372b537a9d870308e3375c17ff96dad488e.tar.gz
upstream-c65d6372b537a9d870308e3375c17ff96dad488e.tar.bz2
upstream-c65d6372b537a9d870308e3375c17ff96dad488e.zip
Add package pwm-gpio-custom
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22350 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/pwm-gpio-custom/Makefile')
-rw-r--r--package/pwm-gpio-custom/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/package/pwm-gpio-custom/Makefile b/package/pwm-gpio-custom/Makefile
new file mode 100644
index 0000000000..24cf096eb2
--- /dev/null
+++ b/package/pwm-gpio-custom/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=pwm-gpio-custom
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/pwm-gpio-custom
+ SUBMENU:=Other modules
+ TITLE:=Custom GPIO-based PWM device
+ DEPENDS:=+kmod-pwm-gpio
+ FILES:=$(PKG_BUILD_DIR)/pwm-gpio-custom.ko
+ KCONFIG:=
+endef
+
+define KernelPackage/pwm-gpio-custom/description
+ Kernel module to register a custom pwm-gpio platform device.
+endef
+
+EXTRA_KCONFIG:= \
+ CONFIG_PWM_GPIO_CUSTOM=m
+
+EXTRA_CFLAGS:= \
+ $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(EXTRA_KCONFIG)))) \
+ $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(EXTRA_KCONFIG))))
+
+MAKE_OPTS:= \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)" \
+ EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
+ $(EXTRA_KCONFIG)
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C "$(LINUX_DIR)" \
+ $(MAKE_OPTS) \
+ modules
+endef
+
+$(eval $(call KernelPackage,pwm-gpio-custom))
+