aboutsummaryrefslogtreecommitdiffstats
path: root/package/ps3-utils
diff options
context:
space:
mode:
authorYuji Mano <yuji.mano@am.sony.com>2008-04-11 21:21:17 +0000
committerYuji Mano <yuji.mano@am.sony.com>2008-04-11 21:21:17 +0000
commit3ff6d72cddf1d69bfff81861fcdd8ba387d70149 (patch)
tree4444a4dfb452634470c6b3f7bc70a0c2a77672b3 /package/ps3-utils
parentd24367572ba48357b1085cee3b337e44c0665eac (diff)
downloadupstream-3ff6d72cddf1d69bfff81861fcdd8ba387d70149.tar.gz
upstream-3ff6d72cddf1d69bfff81861fcdd8ba387d70149.tar.bz2
upstream-3ff6d72cddf1d69bfff81861fcdd8ba387d70149.zip
Add ps3 target specific utilities package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10791 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ps3-utils')
-rw-r--r--package/ps3-utils/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/ps3-utils/Makefile b/package/ps3-utils/Makefile
new file mode 100644
index 0000000000..38ef225425
--- /dev/null
+++ b/package/ps3-utils/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ps3-utils
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/kernel/people/geoff/cell/ps3-utils/
+PKG_MD5SUM:=92b24e57af516d339fe05f6bf7f36848
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ps3-utils
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=PS3 Linux Utilities
+ DEPENDS:=@TARGET_ps3
+ URL:=http://kernel.org/pub/linux/kernel/people/geoff/cell/ps3-utils/
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default)
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
+endef
+
+define Package/ps3-utils/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/usr/lib
+
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ps3-boot-game-os $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ps3-flash-util $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ps3-video-mode $(1)/usr/bin
+
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libps3-utils.so.* $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,ps3-utils))