aboutsummaryrefslogtreecommitdiffstats
path: root/package/procd
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
commit4ebf19b48fafc8d94e14e4ba779969613b241a6a (patch)
tree9918f890a8915023b49ea30948beb5d048c333fa /package/procd
parent44b1688e6c7b4f16f7165fbd560e1183aef69090 (diff)
downloadupstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.gz
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.bz2
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37007
Diffstat (limited to 'package/procd')
-rw-r--r--package/procd/Makefile40
-rw-r--r--package/procd/files/hotplug-preinit.json20
-rw-r--r--package/procd/files/hotplug.json77
-rw-r--r--package/procd/files/procd.init19
-rw-r--r--package/procd/files/procd.sh171
5 files changed, 0 insertions, 327 deletions
diff --git a/package/procd/Makefile b/package/procd/Makefile
deleted file mode 100644
index b94cd2e78b..0000000000
--- a/package/procd/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=procd
-PKG_VERSION:=2013-06-19
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c23413feeb5179911d623e6ffb84b36671652788
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-CMAKE_INSTALL:=1
-
-PKG_LICENSE:=GPLv2
-PKG_LICENSE_FILES:=
-
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
-
-define Package/procd
- SECTION:=base
- CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt
- TITLE:=OpenWrt system process manager
-endef
-
-define Package/procd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc
-
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
- $(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
- $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
- ln -s /sbin/procd $(1)/sbin/init
-endef
-
-$(eval $(call BuildPackage,procd))
diff --git a/package/procd/files/hotplug-preinit.json b/package/procd/files/hotplug-preinit.json
deleted file mode 100644
index 614b104711..0000000000
--- a/package/procd/files/hotplug-preinit.json
+++ /dev/null
@@ -1,20 +0,0 @@
-[
- [ "case", "ACTION", {
- "add": [
- [ "if",
- [ "has", "FIRMWARE" ],
- [
- [ "exec", "/sbin/hotplug-call", "%SUBSYSTEM%" ],
- [ "load-firmware", "/lib/firmware" ],
- [ "return" ]
- ]
- ],
- ],
- }, ],
- [ "if",
- [ "and",
- [ "eq", "SUBSYSTEM", "button" ],
- ],
- [ "exec", "/etc/rc.button/failsafe" ]
- ],
-]
diff --git a/package/procd/files/hotplug.json b/package/procd/files/hotplug.json
deleted file mode 100644
index c1b45c6e86..0000000000
--- a/package/procd/files/hotplug.json
+++ /dev/null
@@ -1,77 +0,0 @@
-[
- [ "case", "ACTION", {
- "add": [
- [ "if",
- [ "and",
- [ "has", "MAJOR" ],
- [ "has", "MINOR" ],
- ],
- [
- [ "if",
- [ "or",
- [ "eq", "DEVNAME",
- [ "null", "full", "ptmx", "zero" ],
- ],
- [ "regex", "DEVNAME",
- [ "^gpio", "^hvc", "^tty" ],
- ],
- ],
- [
- [ "makedev", "/dev/%DEVNAME%", "0666" ],
- [ "return" ],
- ]
- ],
- [ "if",
- [ "or",
- [ "eq", "DEVNAME", "mapper/control" ],
- [ "regex", "DEVPATH", "^ppp" ],
- ],
- [
- [ "makedev", "/dev/%DEVNAME%", "0600" ],
- [ "return" ],
- ],
- ],
- [ "if",
- [ "has", "DEVNAME" ],
- [ "makedev", "/dev/%DEVNAME%", "0644" ],
- ],
- ],
- ],
- [ "if",
- [ "has", "FIRMWARE" ],
- [
- [ "exec", "/sbin/hotplug-call", "%SUBSYSTEM%" ],
- [ "load-firmware", "/lib/firmware" ],
- [ "return" ]
- ]
- ],
- ],
- "remove" : [
- [ "if",
- [ "and",
- [ "has", "DEVNAME" ],
- [ "has", "MAJOR" ],
- [ "has", "MINOR" ],
- ],
- [ "rm", "/dev/%DEVNAME%" ]
- ]
- ]
- } ],
- [ "if",
- [ "eq", "SUBSYSTEM", "platform" ],
- [ "exec", "/sbin/hotplug-call", "%SUBSYSTEM%" ]
- ],
- [ "if",
- [ "and",
- [ "has", "BUTTON" ],
- [ "eq", "SUBSYSTEM", "button" ],
- ],
- [ "exec", "/etc/rc.button/%BUTTON%" ]
- ],
- [ "if",
- [ "eq", "SUBSYSTEM",
- [ "net", "input", "usb", "ieee1394", "block", "atm", "zaptel", "tty" ]
- ],
- [ "exec", "/sbin/hotplug-call", "%SUBSYSTEM%" ]
- ],
-]
diff --git a/package/procd/files/procd.init b/package/procd/files/procd.init
deleted file mode 100644
index 3df5f48e60..0000000000
--- a/package/procd/files/procd.init
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=11
-
-start_stop() {
- start-stop-daemon $1 -b -m -p /var/run/procd.pid -x /sbin/procd
-}
-
-start() {
- start_stop -S
-}
-
-reload() {
- return
-}
-
-stop() {
- start_stop -K
-}
diff --git a/package/procd/files/procd.sh b/package/procd/files/procd.sh
deleted file mode 100644
index e771e0c156..0000000000
--- a/package/procd/files/procd.sh
+++ /dev/null
@@ -1,171 +0,0 @@
-# procd API:
-#
-# procd_open_service(name, [script]):
-# Initialize a new procd command message containing a service with one or more instances
-#
-# procd_close_service()
-# Send the command message for the service
-#
-# procd_open_instance([name]):
-# Add an instance to the service described by the previous procd_open_service call
-#
-# procd_set_param(type, [value...])
-# Available types:
-# command: command line (array).
-# env: environment variable (passed to the process)
-# data: arbitrary name/value pairs for detecting config changes (table)
-# file: configuration files (array)
-# netdev: bound network device (detects ifindex changes)
-#
-# No space separation is done for arrays/tables - use one function argument per command line argument
-#
-# procd_close_instance():
-# Complete the instance being prepared
-#
-# procd_kill(service, [instance]):
-# Kill a service instance (or all instances)
-#
-
-. $IPKG_INSTROOT/usr/share/libubox/jshn.sh
-
-_PROCD_SERVICE=
-
-_procd_call() {
- local old_cb
-
- json_set_namespace procd old_cb
- "$@"
- json_set_namespace $old_cb
-}
-
-_procd_wrapper() {
- while [ -n "$1" ]; do
- eval "$1() { _procd_call _$1 \"\$@\"; }"
- shift
- done
-}
-
-_procd_ubus_call() {
- local cmd="$1"
-
- ubus call service "$cmd" "$(json_dump)"
- json_cleanup
-}
-
-_procd_open_service() {
- local name="$1"
- local script="$2"
-
- _PROCD_SERVICE="$name"
- _PROCD_INSTANCE_SEQ=0
-
- json_init
- json_add_string name "$name"
- [ -n "$script" ] && json_add_string script "$script"
- json_add_object instances
-}
-
-_procd_close_service() {
- json_close_object
- _procd_ubus_call set
-}
-
-_procd_add_array_data() {
- while [ -n "$1" ]; do
- json_add_string "" "$1"
- shift
- done
-}
-
-_procd_add_array() {
- json_add_array "$1"
- shift
- _procd_add_array_data "$@"
- json_close_array
-}
-
-_procd_add_table_data() {
- while [ -n "$1" ]; do
- local var="${1%%=*}"
- local val="${1#*=}"
- [[ "$1" == "$val" ]] && val=
- json_add_string "$var" "$val"
- shift
- done
-}
-
-_procd_add_table() {
- json_add_object "$1"
- shift
- _procd_add_table_data "$@"
- json_close_object
-}
-
-_procd_open_instance() {
- local name="$1"; shift
-
- _PROCD_INSTANCE_SEQ="$(($_PROCD_INSTANCE_SEQ + 1))"
- name="${name:-instance$_PROCD_INSTANCE_SEQ}"
- json_add_object "$name"
-}
-
-_procd_set_param() {
- local type="$1"; shift
-
- case "$type" in
- env|data)
- _procd_add_table "$type" "$@"
- ;;
- command|netdev|file)
- _procd_add_array "$type" "$@"
- ;;
- nice)
- json_add_int "$type" "$1"
- ;;
- esac
-}
-
-_procd_append_param() {
- local type="$1"; shift
-
- json_select "$type"
- case "$type" in
- env|data)
- _procd_add_table_data "$@"
- ;;
- command|netdev|file)
- _procd_add_array_data "$@"
- ;;
- esac
- json_select ..
-}
-
-_procd_close_instance() {
- json_close_object
-}
-
-_procd_add_instance() {
- _procd_open_instance
- _procd_set_command "$@"
- _procd_close_instance
-}
-
-_procd_kill() {
- local service="$1"
- local instance="$2"
-
- json_init
- [ -n "$service" ] && json_add_string service "$service"
- [ -n "$instance" ] && json_add_string instance "$instance"
- _procd_ubus_call delete
-}
-
-_procd_wrapper \
- procd_open_service \
- procd_close_service \
- procd_add_instance \
- procd_open_instance \
- procd_close_instance \
- procd_set_param \
- procd_append_param \
- procd_kill