aboutsummaryrefslogtreecommitdiffstats
path: root/package/procd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
commit4ebf19b48fafc8d94e14e4ba779969613b241a6a (patch)
tree9918f890a8915023b49ea30948beb5d048c333fa /package/procd/Makefile
parent44b1688e6c7b4f16f7165fbd560e1183aef69090 (diff)
downloadupstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.gz
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.bz2
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37007
Diffstat (limited to 'package/procd/Makefile')
-rw-r--r--package/procd/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/package/procd/Makefile b/package/procd/Makefile
deleted file mode 100644
index b94cd2e78b..0000000000
--- a/package/procd/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=procd
-PKG_VERSION:=2013-06-19
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c23413feeb5179911d623e6ffb84b36671652788
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-CMAKE_INSTALL:=1
-
-PKG_LICENSE:=GPLv2
-PKG_LICENSE_FILES:=
-
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
-
-define Package/procd
- SECTION:=base
- CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt
- TITLE:=OpenWrt system process manager
-endef
-
-define Package/procd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc
-
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
- $(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
- $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
- ln -s /sbin/procd $(1)/sbin/init
-endef
-
-$(eval $(call BuildPackage,procd))