aboutsummaryrefslogtreecommitdiffstats
path: root/package/pptp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-28 00:30:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-28 00:30:09 +0000
commit2d4f11f14d12b5af47929864406ff906ac495e65 (patch)
treeb12fb9fdb862e1ba69db83b645b0d40e20bec198 /package/pptp
parent514a1ecd3513baafa44db0660a4306cc0dc0f3d9 (diff)
downloadupstream-2d4f11f14d12b5af47929864406ff906ac495e65.tar.gz
upstream-2d4f11f14d12b5af47929864406ff906ac495e65.tar.bz2
upstream-2d4f11f14d12b5af47929864406ff906ac495e65.zip
[package] pptp: support interface sections without ifname by implementing scan_pptp()
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21590 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/pptp')
-rw-r--r--package/pptp/Makefile2
-rw-r--r--package/pptp/files/pptp.sh4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
index 018e9b570e..a55309bf51 100644
--- a/package/pptp/Makefile
+++ b/package/pptp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pptp
PKG_VERSION:=1.7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/pptpclient
diff --git a/package/pptp/files/pptp.sh b/package/pptp/files/pptp.sh
index c95895d9fa..436bee3c87 100644
--- a/package/pptp/files/pptp.sh
+++ b/package/pptp/files/pptp.sh
@@ -2,6 +2,10 @@ find_gw() {
route -n | awk '$1 == "0.0.0.0" { print $2; exit }'
}
+scan_pptp() {
+ config_set "$1" device "pptp-$1"
+}
+
stop_interface_pptp() {
stop_interface_ppp "$1"
}