aboutsummaryrefslogtreecommitdiffstats
path: root/package/pptp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-05 16:56:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-05 16:56:28 +0000
commitb8a49d3b901aa9b9095fa1b3049c1cb7b46a0436 (patch)
tree0598df8efd13fecb41a7ff593a0959d3c98f61b6 /package/pptp/Makefile
parent9f5b2e94475b8074928faf746df945d1c72759db (diff)
downloadupstream-b8a49d3b901aa9b9095fa1b3049c1cb7b46a0436.tar.gz
upstream-b8a49d3b901aa9b9095fa1b3049c1cb7b46a0436.tar.bz2
upstream-b8a49d3b901aa9b9095fa1b3049c1cb7b46a0436.zip
pptp: add netifd support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31605 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/pptp/Makefile')
-rw-r--r--package/pptp/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
index 3772adb064..e44806bdd2 100644
--- a/package/pptp/Makefile
+++ b/package/pptp/Makefile
@@ -36,13 +36,24 @@ endef
MAKE_FLAGS += OPTIMIZE="$(TARGET_CFLAGS)"
-define Package/pptp/install
+ifneq ($(CONFIG_PACKAGE_netifd),)
+ define Package/pptp/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/ppp
$(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
$(INSTALL_DIR) $(1)/lib/network
$(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
-endef
+ endef
+else
+ define Package/pptp/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/ppp
+ $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files.old/pptp.sh $(1)/lib/network/
+ endef
+endif
$(eval $(call BuildPackage,pptp))