aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-07 01:12:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-07 01:12:51 +0000
commitbe5c7d2d2546417767bc5c3471b246fa4f94313e (patch)
tree302a83f06c200757c896bbabe23db4af10445042 /package/ppp
parent816e158a73c253f73d53ec19c73cf6c7ea2e3736 (diff)
downloadupstream-be5c7d2d2546417767bc5c3471b246fa4f94313e.tar.gz
upstream-be5c7d2d2546417767bc5c3471b246fa4f94313e.tar.bz2
upstream-be5c7d2d2546417767bc5c3471b246fa4f94313e.zip
add hotplug stuff to trunk/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2364 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp')
-rw-r--r--package/ppp/Makefile4
-rwxr-xr-xpackage/ppp/files/etc/ppp/ip-down2
-rwxr-xr-xpackage/ppp/files/etc/ppp/ip-up2
-rw-r--r--package/ppp/files/ifup.pppoa1
-rw-r--r--package/ppp/files/ifup.pppoe1
5 files changed, 9 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 1b20c4e7cd..eec2bd8462 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.3
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
@@ -82,6 +82,8 @@ $(IPKG_PPP):
ln -sf /tmp/resolv.conf $(IDIR_PPP)/etc/ppp/resolv.conf
install -m0600 ./files/etc/ppp/chap-secrets $(IDIR_PPP)/etc/ppp/
install -m0644 ./files/etc/ppp/options $(IDIR_PPP)/etc/ppp/
+ install -m0755 ./files/etc/ppp/ip-up $(IDIR_PPP)/etc/ppp/
+ install -m0755 ./files/etc/ppp/ip-down $(IDIR_PPP)/etc/ppp/
install -d -m0755 $(IDIR_PPP)/etc/ppp/peers
install -m0644 ./files/etc/ppp/peers/sample $(IDIR_PPP)/etc/ppp/peers/
install -d -m0755 $(IDIR_PPP)/usr/sbin
diff --git a/package/ppp/files/etc/ppp/ip-down b/package/ppp/files/etc/ppp/ip-down
new file mode 100755
index 0000000000..044759fbf1
--- /dev/null
+++ b/package/ppp/files/etc/ppp/ip-down
@@ -0,0 +1,2 @@
+#!/bin/sh
+[ -z "$6" ] || env -i ACTION="ifdown" INTERFACE="$6" PROTO=ppp /sbin/hotplug "iface"
diff --git a/package/ppp/files/etc/ppp/ip-up b/package/ppp/files/etc/ppp/ip-up
new file mode 100755
index 0000000000..c67a3d03c5
--- /dev/null
+++ b/package/ppp/files/etc/ppp/ip-up
@@ -0,0 +1,2 @@
+#!/bin/sh
+[ -z "$6" ] || env -i ACTION="ifup" INTERFACE="$6" PROTO=ppp /sbin/hotplug "iface"
diff --git a/package/ppp/files/ifup.pppoa b/package/ppp/files/ifup.pppoa
index 51b0fe3344..8928366364 100644
--- a/package/ppp/files/ifup.pppoa
+++ b/package/ppp/files/ifup.pppoa
@@ -31,6 +31,7 @@ while :; do
usepeerdns \
defaultroute \
linkname $type \
+ ipparam $type \
user "$USERNAME" \
password "$PASSWORD" \
mtu $MTU mru $MTU \
diff --git a/package/ppp/files/ifup.pppoe b/package/ppp/files/ifup.pppoe
index 9a5d0a3494..da9a441ad9 100644
--- a/package/ppp/files/ifup.pppoe
+++ b/package/ppp/files/ifup.pppoe
@@ -32,6 +32,7 @@ while :; do
usepeerdns \
defaultroute \
linkname $type \
+ ipparam $type \
user "$USERNAME" \
password "$PASSWORD" \
mtu $MTU mru $MTU \