aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-30 16:06:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-30 16:06:20 +0000
commitc1e312a84daaf7dd0647685a1bcca53467c3e57d (patch)
treed72cdf4e7f6eec7610e1a3f25eb44ed19a19fa80 /package/ppp
parent7dbf48065f095b8b8b31937fbfb46eaa8fd826e9 (diff)
downloadupstream-c1e312a84daaf7dd0647685a1bcca53467c3e57d.tar.gz
upstream-c1e312a84daaf7dd0647685a1bcca53467c3e57d.tar.bz2
upstream-c1e312a84daaf7dd0647685a1bcca53467c3e57d.zip
[package] ppp: add dns servers to uci state in the ip-up script
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17801 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp')
-rw-r--r--package/ppp/Makefile2
-rwxr-xr-xpackage/ppp/files/etc/ppp/ip-up3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 919e105bbb..893c84dfea 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/files/etc/ppp/ip-up b/package/ppp/files/etc/ppp/ip-up
index 46c8d37700..ecdd00b1c4 100755
--- a/package/ppp/files/etc/ppp/ip-up
+++ b/package/ppp/files/etc/ppp/ip-up
@@ -13,6 +13,9 @@ export PPP_IFACE PPP_TTY PPP_SPEED PPP_LOCAL PPP_REMOTE PPP_IPPARAM
uci_set_state network "$PPP_IPPARAM" unit "$PPP_UNIT"
uci_set_state network "$PPP_IPPARAM" ipaddr "$PPP_LOCAL"
uci_set_state network "$PPP_IPPARAM" gateway "$PPP_REMOTE"
+
+ local dns="$DNS1${DNS2:+ $DNS2}"
+ [ -n "$dns" ] && uci_set_state network "$PPP_IPPARAM" dns "$dns"
}
[ -z "$PPP_IPPARAM" ] || env -i ACTION="ifup" INTERFACE="$PPP_IPPARAM" DEVICE="$PPP_IFACE" PROTO=ppp /sbin/hotplug-call "iface"