aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-20 17:56:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-20 17:56:29 +0000
commit93a0a1bfeaffaf8f3e135842a6ed0b0868852f9a (patch)
treef8dab4ecff5a014aebb657cd189b4841eb9fb800 /package/ppp
parent900d12acb7c8deddd0596cbf84453c8e937ed888 (diff)
downloadupstream-93a0a1bfeaffaf8f3e135842a6ed0b0868852f9a.tar.gz
upstream-93a0a1bfeaffaf8f3e135842a6ed0b0868852f9a.tar.bz2
upstream-93a0a1bfeaffaf8f3e135842a6ed0b0868852f9a.zip
[package] pppd: use "atmdev" option to select the DSL adapter, this aligns it with br2684ctl and solves #8108
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23551 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp')
-rw-r--r--package/ppp/Makefile2
-rw-r--r--package/ppp/files/pppoa.sh6
2 files changed, 4 insertions, 4 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index b893b1ec52..eae32d0439 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=12
+PKG_RELEASE:=13
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/files/pppoa.sh b/package/ppp/files/pppoa.sh
index 59e35c2dca..df947aa83d 100644
--- a/package/ppp/files/pppoa.sh
+++ b/package/ppp/files/pppoa.sh
@@ -9,8 +9,8 @@ stop_interface_pppoa() {
setup_interface_pppoa() {
local config="$2"
- local device
- config_get device "$config" device
+ local atmdev
+ config_get atmdev "$config" atmdev
local vpi
config_get vpi "$config" vpi
@@ -34,6 +34,6 @@ setup_interface_pppoa() {
config_get mtu "$config" mtu
start_pppd "$config" \
- plugin pppoatm.so ${device:+$device.}${vpi:-8}.${vci:-35} \
+ plugin pppoatm.so ${atmdev:+$atmdev.}${vpi:-8}.${vci:-35} \
${encaps} ${mtu:+mtu $mtu mru $mtu}
}