aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-04-20 12:02:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-04-20 12:02:04 +0000
commit4e52672d7ecb2ce2bdba297e02948f61b5d8c445 (patch)
tree3ac6cf576a2176317619af6ec9c221ce0ad31cd7 /package/ppp
parent35791d9e95298c6a1e562d8a3ff151b6bd7430c9 (diff)
downloadupstream-4e52672d7ecb2ce2bdba297e02948f61b5d8c445.tar.gz
upstream-4e52672d7ecb2ce2bdba297e02948f61b5d8c445.tar.bz2
upstream-4e52672d7ecb2ce2bdba297e02948f61b5d8c445.zip
[package] ppp: prevent duplicate hotplug for non uci managed ppp interfaces (#9275)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26742 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp')
-rw-r--r--package/ppp/Makefile4
-rwxr-xr-xpackage/ppp/files/etc/ppp/ip-up9
2 files changed, 10 insertions, 3 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 992d966497..3aefed3142 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=16
+PKG_RELEASE:=17
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/files/etc/ppp/ip-up b/package/ppp/files/etc/ppp/ip-up
index 3895929539..353f667895 100755
--- a/package/ppp/files/etc/ppp/ip-up
+++ b/package/ppp/files/etc/ppp/ip-up
@@ -20,7 +20,14 @@ export PPP_IFACE PPP_TTY PPP_SPEED PPP_LOCAL PPP_REMOTE PPP_IPPARAM
[ -n "$dns" ] && add_dns "$PPP_IPPARAM" $dns
}
-[ -z "$PPP_IPPARAM" ] || env -i ACTION="ifup" INTERFACE="$PPP_IPPARAM" DEVICE="$PPP_IFACE" PROTO=ppp /sbin/hotplug-call "iface"
+[ -z "$PPP_IPPARAM" ] || {
+ case "$PPP_IFACE" in
+ # only handle uci managed interfaces here, others are done by generic hotplug
+ 3g-*|ppp-*|pppoa-*|pppoe-*|pptp-*)
+ env -i ACTION="ifup" INTERFACE="$PPP_IPPARAM" DEVICE="$PPP_IFACE" PROTO=ppp /sbin/hotplug-call "iface"
+ ;;
+ esac
+}
[ -d /etc/ppp/ip-up.d ] && {
for SCRIPT in /etc/ppp/ip-up.d/*