aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-26 15:52:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-26 15:52:12 +0000
commit7dd7852ba2d9ab29c610461ed61c2428c34e8759 (patch)
treecc27fd3cfca0cccad6db8cbd6ffe811e5adea94a /package/ppp/patches
parent1a001483d28c98e8a392a9dc21c95aaf947b4d07 (diff)
downloadupstream-7dd7852ba2d9ab29c610461ed61c2428c34e8759.tar.gz
upstream-7dd7852ba2d9ab29c610461ed61c2428c34e8759.tar.bz2
upstream-7dd7852ba2d9ab29c610461ed61c2428c34e8759.zip
clean up board-dependent files, add pppoatm support, add proper config examples
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/patches')
-rw-r--r--package/ppp/patches/202-atm_fix.patch21
-rw-r--r--package/ppp/patches/202-no_atm.patch12
2 files changed, 21 insertions, 12 deletions
diff --git a/package/ppp/patches/202-atm_fix.patch b/package/ppp/patches/202-atm_fix.patch
new file mode 100644
index 0000000000..371dc9611e
--- /dev/null
+++ b/package/ppp/patches/202-atm_fix.patch
@@ -0,0 +1,21 @@
+--- ppp-2.4.3/pppd/plugins/pppoatm/pppoatm.c 2005-08-26 15:18:55.000000000 +0200
++++ ppp-2.4.3/pppd/plugins/pppoatm/pppoatm.c 2005-08-26 15:19:51.000000000 +0200
+@@ -136,8 +136,6 @@
+ int fd;
+ struct atm_qos qos;
+
+- system ("/sbin/modprobe pppoatm");
+-
+ if (!device_got_set)
+ no_device_given_pppoatm();
+ fd = socket(AF_ATMPVC, SOCK_DGRAM, 0);
+@@ -152,8 +150,7 @@
+ qos.txtp.max_sdu = lcp_allowoptions[0].mru + pppoatm_overhead();
+ qos.rxtp.max_sdu = lcp_wantoptions[0].mru + pppoatm_overhead();
+ qos.aal = ATM_AAL5;
+- if (setsockopt(fd, SOL_ATM, SO_ATMQOS, &qos, sizeof(qos)) < 0)
+- fatal("setsockopt(SO_ATMQOS): %m");
++ setsockopt(fd, SOL_ATM, SO_ATMQOS, &qos, sizeof(qos));
+ /* TODO: accept on SVCs... */
+ if (connect(fd, (struct sockaddr *) &pvcaddr,
+ sizeof(struct sockaddr_atmpvc)))
diff --git a/package/ppp/patches/202-no_atm.patch b/package/ppp/patches/202-no_atm.patch
deleted file mode 100644
index a737cfa23a..0000000000
--- a/package/ppp/patches/202-no_atm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN ppp-2.4.3-orig/pppd/plugins/Makefile.linux ppp-2.4.3-3/pppd/plugins/Makefile.linux
---- ppp-2.4.3-orig/pppd/plugins/Makefile.linux 2004-11-14 08:57:35.000000000 +0100
-+++ ppp-2.4.3-3/pppd/plugins/Makefile.linux 2004-12-05 17:03:59.000000000 +0100
-@@ -9,7 +9,7 @@
- MANDIR = $(DESTDIR)/share/man/man8
- LIBDIR = $(DESTDIR)/lib/pppd/$(VERSION)
-
--SUBDIRS := rp-pppoe pppoatm radius
-+SUBDIRS := rp-pppoe radius
- # Uncomment the next line to include the radius authentication plugin
- # SUBDIRS += radius
- PLUGINS := minconn.so passprompt.so passwordfd.so winbind.so