aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-03-20 13:09:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-03-20 13:09:27 +0000
commitf33b5960c7357a5181b725baf3672fa97d071331 (patch)
tree10d7d2da917ab14d7190e4d8db64684d91262529 /package/ppp/Makefile
parentd573506eb100e6a61985872f7b87d6ce21b57fe5 (diff)
downloadupstream-f33b5960c7357a5181b725baf3672fa97d071331.tar.gz
upstream-f33b5960c7357a5181b725baf3672fa97d071331.tar.bz2
upstream-f33b5960c7357a5181b725baf3672fa97d071331.zip
pppd: split files into netifd and non-netifd files, move the netifd ppp.sh file to the pppd package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31041 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile39
1 files changed, 25 insertions, 14 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index e41e87730c..4ace4d9366 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -156,23 +156,40 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/include/pppd $(1)/usr/include/
endef
+ifneq ($(CONFIG_PACKAGE_netifd),)
+ define Package/ppp/script_install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/netifd/proto/
+ endef
+else
+ define Package/ppp/script_install
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_BIN) ./files.old/ppp.sh $(1)/lib/network/
+ $(INSTALL_BIN) ./files.old/etc/ppp/ip-up $(1)/etc/ppp/
+ $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
+ $(INSTALL_BIN) ./files.old/etc/ppp/ip-down $(1)/etc/ppp/
+ $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
+ $(INSTALL_BIN) ./files.old/etc/ppp/ipv6-up $(1)/etc/ppp/
+ $(INSTALL_BIN) ./files.old/etc/ppp/ipv6-down $(1)/etc/ppp/
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_BIN) ./files.old/pppoe.sh $(1)/lib/network/
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_BIN) ./files.old/pppoa.sh $(1)/lib/network/
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
+ $(INSTALL_DATA) ./files.old/etc/hotplug.d/atm/20-atm-modem $(1)/etc/hotplug.d/atm/
+ endef
+endif
+
define Package/ppp/install
$(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppd $(1)/usr/sbin/
- $(INSTALL_DIR) $(1)/lib/network
- $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/network/
$(INSTALL_DIR) $(1)/etc/ppp
$(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
$(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
- $(INSTALL_BIN) ./files/etc/ppp/ip-up $(1)/etc/ppp/
- $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
- $(INSTALL_BIN) ./files/etc/ppp/ip-down $(1)/etc/ppp/
- $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
- $(INSTALL_BIN) ./files/etc/ppp/ipv6-up $(1)/etc/ppp/
- $(INSTALL_BIN) ./files/etc/ppp/ipv6-down $(1)/etc/ppp/
$(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
+ $(Package/ppp/script_install)
endef
Package/ppp-multilink/install=$(Package/ppp/install)
@@ -180,18 +197,12 @@ define Package/ppp-mod-pppoa/install
$(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \
$(1)/usr/lib/pppd/$(PKG_VERSION)/
- $(INSTALL_DIR) $(1)/lib/network
- $(INSTALL_BIN) ./files/pppoa.sh $(1)/lib/network/
- $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
- $(INSTALL_DATA) ./files/etc/hotplug.d/atm/20-atm-modem $(1)/etc/hotplug.d/atm/
endef
define Package/ppp-mod-pppoe/install
$(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
$(1)/usr/lib/pppd/$(PKG_VERSION)/
- $(INSTALL_DIR) $(1)/lib/network
- $(INSTALL_BIN) ./files/pppoe.sh $(1)/lib/network/
endef
define Package/ppp-mod-radius/install