aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-11 20:07:46 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-11 20:07:46 +0000
commitf01263c0a03c53c3e8ffd89120f38dd36fc52f77 (patch)
tree28df53031ba722ec8b05b3bb34e91f04a59812c9 /package/ppp/Makefile
parent4cd76147156752d0389d20aab6aa666af3ec9a82 (diff)
downloadupstream-f01263c0a03c53c3e8ffd89120f38dd36fc52f77.tar.gz
upstream-f01263c0a03c53c3e8ffd89120f38dd36fc52f77.tar.bz2
upstream-f01263c0a03c53c3e8ffd89120f38dd36fc52f77.zip
[package] ppp: add support for kernel mode pptp
- add ppp-mod-pptp, based on patch by Daniel Golle <dgolle@allnet.de> - add netifd integration for pptp to ppp.sh git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32197 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 27b1f42825..d0bf9eb200 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.5
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
@@ -105,6 +105,16 @@ define Package/ppp-mod-pppol2tp/description
This package contains a PPPoL2TP (PPP over L2TP) plugin for ppp.
endef
+define Package/ppp-mod-pptp
+$(call Package/ppp/Default)
+ DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pptp +kmod-mppe
+ TITLE:=PPtP plugin
+endef
+
+define Package/ppp-mod-pptp/description
+This package contains a PPtP plugin for ppp.
+endef
+
define Package/chat
$(call Package/ppp/Default)
DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
@@ -216,6 +226,14 @@ define Package/ppp-mod-pppol2tp/install
$(1)/usr/lib/pppd/$(PKG_VERSION)/
endef
+define Package/ppp-mod-pptp/install
+ $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pptp.so \
+ $(1)/usr/lib/pppd/$(PKG_VERSION)/
+ $(INSTALL_DIR) $(1)/etc/ppp
+ $(INSTALL_DATA) ./files/etc/ppp/options.pptp $(1)/etc/ppp/
+endef
+
define Package/chat/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/chat $(1)/usr/sbin/
@@ -237,6 +255,7 @@ $(eval $(call BuildPackage,ppp-mod-pppoa))
$(eval $(call BuildPackage,ppp-mod-pppoe))
$(eval $(call BuildPackage,ppp-mod-radius))
$(eval $(call BuildPackage,ppp-mod-pppol2tp))
+$(eval $(call BuildPackage,ppp-mod-pptp))
$(eval $(call BuildPackage,chat))
$(eval $(call BuildPackage,pppdump))
$(eval $(call BuildPackage,pppstats))