aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-03 09:38:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-03 09:38:58 +0000
commit5901da9cc813449f90911d131c6c779928a65324 (patch)
tree1c5ab9dd6bf63e3c603fdc2e61782f560f03a1db /package/ppp/Makefile
parentdab41fab68822525c4a5d449ffeb44d73b70f385 (diff)
downloadupstream-5901da9cc813449f90911d131c6c779928a65324.tar.gz
upstream-5901da9cc813449f90911d131c6c779928a65324.tar.bz2
upstream-5901da9cc813449f90911d131c6c779928a65324.zip
Add ppp-mod-pppol2tp subpackage to ppp
Signed-off-by: David Woodhouse <David.Woodhouse@intel.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31564 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index ed86a8ae45..b60ae7cb68 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.5
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
@@ -95,6 +95,16 @@ define Package/ppp-mod-radius/conffiles
/etc/ppp/radius/
endef
+define Package/ppp-mod-pppol2tp
+$(call Package/ppp/Default)
+ DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppol2tp
+ TITLE:=PPPoL2TP plugin
+endef
+
+define Package/ppp-mod-pppol2tp/description
+This package contains a PPPoL2TP (PPP over L2TP) plugin for ppp.
+endef
+
define Package/chat
$(call Package/ppp/Default)
DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
@@ -220,6 +230,12 @@ define Package/ppp-mod-radius/install
$(1)/etc/ppp/radius/
endef
+define Package/ppp-mod-pppol2tp/install
+ $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppol2tp.so \
+ $(1)/usr/lib/pppd/$(PKG_VERSION)/
+endef
+
define Package/chat/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/chat $(1)/usr/sbin/
@@ -240,6 +256,7 @@ $(eval $(call BuildPackage,ppp-multilink))
$(eval $(call BuildPackage,ppp-mod-pppoa))
$(eval $(call BuildPackage,ppp-mod-pppoe))
$(eval $(call BuildPackage,ppp-mod-radius))
+$(eval $(call BuildPackage,ppp-mod-pppol2tp))
$(eval $(call BuildPackage,chat))
$(eval $(call BuildPackage,pppdump))
$(eval $(call BuildPackage,pppstats))