aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-03-18 17:27:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-03-18 17:27:20 +0000
commit5359dd8c8a0ad7c6c3ea7f0211b26b378263965f (patch)
tree52813f9ebd13e23690eceb048dcb8cfb54863a17 /package/ppp/Makefile
parenta10c122fe2cdd175541eb14cebe58d599b5c7dce (diff)
downloadupstream-5359dd8c8a0ad7c6c3ea7f0211b26b378263965f.tar.gz
upstream-5359dd8c8a0ad7c6c3ea7f0211b26b378263965f.tar.bz2
upstream-5359dd8c8a0ad7c6c3ea7f0211b26b378263965f.zip
precompile ppp active filter (reduces libpcap overhead to only a few k), enable by default to support proper demand dialling, fixes #307
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3401 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index d98d7e5cb7..e63fa4cf50 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -41,8 +41,7 @@ $(eval $(call PKG_mod_template,PPP_MOD_RADIUS,radius))
PKG_DEPEND:="kmod-ppp"
ifeq ($(BR2_PACKAGE_PPP_WITH_FILTER),y)
-ENABLE_FILTER:="FILTER=1"
-PKG_DEPEND += ", libpcap"
+ENABLE_FILTER:="PRECOMPILED_FILTER=1"
endif
$(PKG_BUILD_DIR)/.configured:
@@ -85,11 +84,16 @@ $(PKG_BUILD_DIR)/.built:
all install
touch $@
+ifeq ($(BR2_PACKAGE_PPP_WITH_FILTER),y)
+INSTALL_FILTER=install -m0644 ./files/etc/ppp/filter $(IDIR_PPP)/etc/ppp/
+endif
+
$(IPKG_PPP):
install -d -m0755 $(IDIR_PPP)/etc/ppp
ln -sf /tmp/resolv.conf $(IDIR_PPP)/etc/ppp/resolv.conf
install -m0600 ./files/etc/ppp/chap-secrets $(IDIR_PPP)/etc/ppp/
install -m0644 ./files/etc/ppp/options $(IDIR_PPP)/etc/ppp/
+ $(INSTALL_FILTER)
install -m0755 ./files/etc/ppp/ip-up $(IDIR_PPP)/etc/ppp/
install -m0755 ./files/etc/ppp/ip-down $(IDIR_PPP)/etc/ppp/
install -d -m0755 $(IDIR_PPP)/usr/sbin