aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-07 01:22:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-07 01:22:48 +0000
commit4c686abd91aab45c07b75063be2a081e7f8cec38 (patch)
tree9441db39cb28cdf7f5634ffc9261adc38f9ab85c /package/ppp/Makefile
parent58cc0f2aceaa138174e6da26cd2ecc2a1fa3b66c (diff)
downloadupstream-4c686abd91aab45c07b75063be2a081e7f8cec38.tar.gz
upstream-4c686abd91aab45c07b75063be2a081e7f8cec38.tar.bz2
upstream-4c686abd91aab45c07b75063be2a081e7f8cec38.zip
[package] ppp:
- don't let pppd control resolv.conf.auto because it will wipe foreign dns entries - handle dns setup in ip-up handler - use add_dns() and remove_dns() to only add/remove dns entries related to the corresponding pppd instance - make pppd shutdown work for interfaces without ifname option, e.g. pptp git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21392 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 66f72de21d..e90d4ccfac 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -140,7 +140,7 @@ define Package/ppp/install
$(INSTALL_BIN) ./files/etc/ppp/ipv6-up $(1)/etc/ppp/
$(INSTALL_BIN) ./files/etc/ppp/ipv6-down $(1)/etc/ppp/
$(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
- ln -sf /tmp/resolv.conf.auto $(1)/etc/ppp/resolv.conf
+ ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
endef
define Package/ppp-mod-pppoa/install