aboutsummaryrefslogtreecommitdiffstats
path: root/package/portsentry
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-16 19:17:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-16 19:17:17 +0000
commitf2c6f48cf523194d3b2d76b095706044e986d953 (patch)
tree6bf5f55313ee1c06ec631f40ac3804410140edc8 /package/portsentry
parentec04e38bb48e06e9ab0494f928184fd1468ad945 (diff)
downloadupstream-f2c6f48cf523194d3b2d76b095706044e986d953.tar.gz
upstream-f2c6f48cf523194d3b2d76b095706044e986d953.tar.bz2
upstream-f2c6f48cf523194d3b2d76b095706044e986d953.zip
add portsentry package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1469 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/portsentry')
-rw-r--r--package/portsentry/Config.in8
-rw-r--r--package/portsentry/Makefile34
-rw-r--r--package/portsentry/ipkg/portsentry.conffiles1
-rw-r--r--package/portsentry/ipkg/portsentry.control6
-rw-r--r--package/portsentry/patches/100-conf_location.patch11
-rw-r--r--package/portsentry/patches/101-postsentry_c.patch12
6 files changed, 72 insertions, 0 deletions
diff --git a/package/portsentry/Config.in b/package/portsentry/Config.in
new file mode 100644
index 0000000000..aa85b870b8
--- /dev/null
+++ b/package/portsentry/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PORTSENTRY
+ tristate "portsentry"
+ default m if CONFIG_DEVEL
+ help
+ Software for protection against port scans
+
+ http://sourceforge.net/projects/sentrytools
+
diff --git a/package/portsentry/Makefile b/package/portsentry/Makefile
new file mode 100644
index 0000000000..7c5dd3cf71
--- /dev/null
+++ b/package/portsentry/Makefile
@@ -0,0 +1,34 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=portsentry
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
+
+PKG_SOURCE_URL:=@SF/sentrytools
+PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PORTSENTRY,portsentry,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) linux
+ touch $@
+
+$(IPKG_PORTSENTRY):
+ mkdir -p $(IDIR_PORTSENTRY)/usr/bin
+ mkdir -p $(IDIR_PORTSENTRY)/etc
+ cp $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(IDIR_PORTSENTRY)/etc/
+ cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_PORTSENTRY)/usr/bin/
+ $(STRIP) $(IDIR_PORTSENTRY)/usr/bin/*
+ $(IPKG_BUILD) $(IDIR_PORTSENTRY) $(PACKAGE_DIR)
+
+mostlyclean:
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ rm -f $(PKG_BUILD_DIR)/.built
diff --git a/package/portsentry/ipkg/portsentry.conffiles b/package/portsentry/ipkg/portsentry.conffiles
new file mode 100644
index 0000000000..9c0810ccbe
--- /dev/null
+++ b/package/portsentry/ipkg/portsentry.conffiles
@@ -0,0 +1 @@
+/etc/portsentry.conf
diff --git a/package/portsentry/ipkg/portsentry.control b/package/portsentry/ipkg/portsentry.control
new file mode 100644
index 0000000000..bf8fe42cdb
--- /dev/null
+++ b/package/portsentry/ipkg/portsentry.control
@@ -0,0 +1,6 @@
+Package: portsentry
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <openwrt@nbd.name>
+Source: buildroot internal
+Description: Software for protection against port scans
diff --git a/package/portsentry/patches/100-conf_location.patch b/package/portsentry/patches/100-conf_location.patch
new file mode 100644
index 0000000000..457c9c827b
--- /dev/null
+++ b/package/portsentry/patches/100-conf_location.patch
@@ -0,0 +1,11 @@
+--- portsentry/portsentry_config.h 2003-05-23 20:10:13.000000000 +0200
++++ portsentry.old/portsentry_config.h 2005-07-09 21:21:15.000000000 +0200
+@@ -22,7 +22,7 @@
+
+ /* These are probably ok. Be sure you change the Makefile if you */
+ /* change the path */
+-#define CONFIG_FILE "/usr/local/psionic/portsentry/portsentry.conf"
++#define CONFIG_FILE "/etc/portsentry.conf"
+
+ /* The location of Wietse Venema's TCP Wrapper hosts.deny file */
+ #define WRAPPER_HOSTS_DENY "/etc/hosts.deny"
diff --git a/package/portsentry/patches/101-postsentry_c.patch b/package/portsentry/patches/101-postsentry_c.patch
new file mode 100644
index 0000000000..e36bb2a123
--- /dev/null
+++ b/package/portsentry/patches/101-postsentry_c.patch
@@ -0,0 +1,12 @@
+--- portsentry/portsentry.c 2003-05-23 20:10:13.000000000 +0200
++++ portsentry.old/portsentry.c 2005-07-09 21:57:24.000000000 +0200
+@@ -1581,8 +1581,7 @@
+ Usage (void)
+ {
+ printf ("PortSentry - Port Scan Detector.\n");
+- printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot
+-sourceforget dot net>\n");
++ printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot sourceforget dot net>\n");
+ printf ("Licensing restrictions apply. Please see documentation\n");
+ printf ("Version: %s\n\n", VERSION);
+ #ifdef SUPPORT_STEALTH