aboutsummaryrefslogtreecommitdiffstats
path: root/package/platform/lantiq/ltq-vdsl-mei/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
commit4ebf19b48fafc8d94e14e4ba779969613b241a6a (patch)
tree9918f890a8915023b49ea30948beb5d048c333fa /package/platform/lantiq/ltq-vdsl-mei/Makefile
parent44b1688e6c7b4f16f7165fbd560e1183aef69090 (diff)
downloadupstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.gz
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.bz2
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37007
Diffstat (limited to 'package/platform/lantiq/ltq-vdsl-mei/Makefile')
-rw-r--r--package/platform/lantiq/ltq-vdsl-mei/Makefile60
1 files changed, 0 insertions, 60 deletions
diff --git a/package/platform/lantiq/ltq-vdsl-mei/Makefile b/package/platform/lantiq/ltq-vdsl-mei/Makefile
deleted file mode 100644
index 8561573f7d..0000000000
--- a/package/platform/lantiq/ltq-vdsl-mei/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=ltq-vdsl-vr9-mei
-PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
-
-PKG_BASE_NAME:=drv_mei_cpe
-PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
-PKG_MD5SUM:=cf2fccc1bc72390b2aec46650abf2f20
-PKG_FIXUP:=autoreconf
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/ltq-vdsl-vr9-mei
- TITLE:=mei driver for vdsl
- SECTION:=sys
- SUBMENU:=Network Devices
- DEPENDS:=@TARGET_lantiq_xway +kmod-ltq-ifxos
- FILES:=$(PKG_BUILD_DIR)/src/drv_mei_cpe.ko
- AUTOLOAD:=$(call AutoLoad,50,drv_mei_cpe)
-endef
-
-define KernelPackage/ltq-vdsl-vr9-mei/description
- Lantiq MEI CPE Kernel Module Driver
-endef
-
-#DEBUG=-DDEBUG_PRINT=1
-
-CONFIGURE_ARGS += \
- --enable-kernelincl="$(LINUX_DIR)/include" \
- --enable-device=vr9 \
- --with-max-device=1 \
- --with-lines-per-device=1 \
- --enable-debug \
- --enable-error_print \
- --enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos/" \
- --enable-ifxos-library="-L$(STAGING_DIR)/usr/lib" \
- --enable-add_drv_cflags="$(DEBUG) -DMEI_DRV_ATM_PTM_INTERFACE_ENABLE=1 -fno-pic -mno-abicalls -mlong-calls -O2 -g0" \
- --enable-linux-26 \
- --enable-kernelbuild="$(LINUX_DIR)" \
- ARCH=$(LINUX_KARCH)
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include/vdsl
- $(CP) $(PKG_BUILD_DIR)/src/drv_mei_cpe_api_intern.h $(1)/usr/include/vdsl/
- $(CP) $(PKG_BUILD_DIR)/src/drv_mei_cpe_api_atm_ptm_intern.h $(1)/usr/include/vdsl/
- $(CP) $(PKG_BUILD_DIR)/src/drv_mei_cpe_interface.h $(1)/usr/include/vdsl
- $(CP) $(PKG_BUILD_DIR)/src/drv_mei_cpe_config.h $(1)/usr/include/vdsl/
- $(CP) $(PKG_BUILD_DIR)/src/cmv_message_format.h $(1)/usr/include/vdsl/
-endef
-
-$(eval $(call KernelPackage,ltq-vdsl-vr9-mei))