aboutsummaryrefslogtreecommitdiffstats
path: root/package/pjsip
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-03 17:38:52 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-03 17:38:52 +0000
commit4e97f76c3b1e25605c00089e523bba0775cf12c6 (patch)
treec4b27550ebd98cf18efc82606ecb6fd71eecba49 /package/pjsip
parent945713a874d0b331dd5ee6e0e4f7101035e1e274 (diff)
downloadupstream-4e97f76c3b1e25605c00089e523bba0775cf12c6.tar.gz
upstream-4e97f76c3b1e25605c00089e523bba0775cf12c6.tar.bz2
upstream-4e97f76c3b1e25605c00089e523bba0775cf12c6.zip
fixes dependencies of pjsip and ltq-vmmc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27409 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/pjsip')
-rw-r--r--package/pjsip/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/pjsip/Makefile b/package/pjsip/Makefile
index c1021f3594..4f385723ab 100644
--- a/package/pjsip/Makefile
+++ b/package/pjsip/Makefile
@@ -18,6 +18,8 @@ PKG_INSTALL:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/pjproject-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=TARGET_lantiq:kmod-ltq-tapi TARGET_lantiq:kmod-ltq-vmmc
+
include $(INCLUDE_DIR)/package.mk
define Package/pjsip-template
@@ -64,7 +66,7 @@ EXTRA_CFLAGS:=-I$(STAGING_DIR)/usr/include/drv_tapi -I$(STAGING_DIR)/usr/include
endif
Package/pjsip-oss=$(call Package/pjsip-template,oss,)
-Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +TARGET_lantiq:kmod-ltq-tapi +TARGET_lantiq:kmod-ltq-vmmc)
+Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +kmod-ltq-tapi +kmod-ltq-vmmc)
define Build/Prepare
$(PKG_UNPACK)