aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-28 02:18:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-28 02:18:16 +0000
commit503d7a462b824c01dd6b0fbadcfdf3e76355de35 (patch)
tree86fb2049c2b8714f2ac101dd0f7144d1a63007fc /package/opkg
parent0a99e514e78a194a4b561f071af5026e99d6bec7 (diff)
downloadupstream-503d7a462b824c01dd6b0fbadcfdf3e76355de35.tar.gz
upstream-503d7a462b824c01dd6b0fbadcfdf3e76355de35.tar.bz2
upstream-503d7a462b824c01dd6b0fbadcfdf3e76355de35.zip
[buildsystem] revert r22372 and r22405, dependency on host libtool causes problems
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22406 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile24
1 files changed, 0 insertions, 24 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 3a5ba449f1..c18f8e7319 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -18,9 +18,7 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_FIXUP = libtool
-
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
define Package/opkg
SECTION:=base
@@ -82,25 +80,3 @@ define Build/InstallDev
endef
$(eval $(call BuildPackage,opkg))
-
-
-HOST_CONFIGURE_ARGS += \
- --disable-curl \
- --disable-gpg \
- --with-opkgetcdir=/etc \
- --with-opkglockfile=/tmp/opkg.lock
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
- $(call Host/Configure/Default)
-endef
-
-define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
-endef
-
-define Host/Install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
-endef
-
-$(eval $(call HostBuild))