aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-24 00:08:08 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-24 00:08:08 +0000
commit21d7852de0baa1bb6b466a887d227e243df593ee (patch)
tree3f7b5cda53614c4d991f4cadfc607c18dfcf02d1 /package/opkg
parente80fb36f396323d88d8bdf192d93dceeb6be2dbd (diff)
downloadupstream-21d7852de0baa1bb6b466a887d227e243df593ee.tar.gz
upstream-21d7852de0baa1bb6b466a887d227e243df593ee.tar.bz2
upstream-21d7852de0baa1bb6b466a887d227e243df593ee.zip
replace some -I & -L flags with $(TARGET_CPPFLAGS) & $(TARGET_LDFLAGS) when appropriate
SVN-Revision: 14651
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 6a857905b7..8a06ec0726 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -41,8 +41,8 @@ define Package/opkg/conffiles
endef
TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3),-Wno-array-bounds)
-EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
-EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
CONFIGURE_ARGS += \
--disable-curl \