aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-23 19:49:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-23 19:49:19 +0000
commitfc7a57fa5d5105a8d4fe193a2401794ee361c7ea (patch)
treec4a5dc7b3b75b5717570464e0b8352097d7df109 /package/opkg
parent1e8591f79be8a792cc4dd60589441fc44477824d (diff)
downloadupstream-fc7a57fa5d5105a8d4fe193a2401794ee361c7ea.tar.gz
upstream-fc7a57fa5d5105a8d4fe193a2401794ee361c7ea.tar.bz2
upstream-fc7a57fa5d5105a8d4fe193a2401794ee361c7ea.zip
[buildsystem] use host opkg for installing packages in buildroot and ImageBuilder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22372 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index c18f8e7319..3a5ba449f1 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -18,7 +18,9 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_FIXUP = libtool
+
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/opkg
SECTION:=base
@@ -80,3 +82,25 @@ define Build/InstallDev
endef
$(eval $(call BuildPackage,opkg))
+
+
+HOST_CONFIGURE_ARGS += \
+ --disable-curl \
+ --disable-gpg \
+ --with-opkgetcdir=/etc \
+ --with-opkglockfile=/tmp/opkg.lock
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
+ $(call Host/Configure/Default)
+endef
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
+endef
+
+$(eval $(call HostBuild))