aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-14 10:43:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-14 10:43:15 +0000
commit96cdf8345959263cf6c1b1bb29d5082670cb7011 (patch)
tree5411e0e653d277bc5dc2ba1450565e7acc38e21c /package/opkg
parent128642a1d818deadd5853ca045265397f2836f72 (diff)
downloadupstream-96cdf8345959263cf6c1b1bb29d5082670cb7011.tar.gz
upstream-96cdf8345959263cf6c1b1bb29d5082670cb7011.tar.bz2
upstream-96cdf8345959263cf6c1b1bb29d5082670cb7011.zip
opkg: work around a gcc warning bug related to array bounds checking
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14506 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/patches/005-array_warnings.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/opkg/patches/005-array_warnings.patch b/package/opkg/patches/005-array_warnings.patch
new file mode 100644
index 0000000000..deaffbe33e
--- /dev/null
+++ b/package/opkg/patches/005-array_warnings.patch
@@ -0,0 +1,10 @@
+--- a/libopkg/Makefile.am
++++ b/libopkg/Makefile.am
+@@ -1,6 +1,6 @@
+
+ HOST_CPU=@host_cpu@
+-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
++AM_CFLAGS=-Wall -Werror -Wno-array-bounds -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
+
+ libopkg_includedir=$(includedir)/libopkg
+ libopkg_include_HEADERS= opkg.h