aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-02 12:48:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-02 12:48:04 +0000
commit64eeb3622360be041b6914f49065ce00e101f7a3 (patch)
tree1a2af3eb1206080c53f3f9c561c901b6d058c76c /package/opkg
parenta0088333bdcc700192dc6a7250dcc26809133251 (diff)
downloadupstream-64eeb3622360be041b6914f49065ce00e101f7a3.tar.gz
upstream-64eeb3622360be041b6914f49065ce00e101f7a3.tar.bz2
upstream-64eeb3622360be041b6914f49065ce00e101f7a3.zip
opkg: use -ffunction-sections, -fdata-sections and --gc-sections
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25829 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 25cdc524c6..0b07d5b499 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -46,6 +46,7 @@ define Package/opkg/conffiles
endef
TARGET_CFLAGS += $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CONFIGURE_ARGS += \
@@ -59,6 +60,7 @@ define Build/Compile
CC="$(TARGET_CC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
HOST_CPU="$(PKGARCH)" \
+ LDFLAGS="-Wl,--gc-sections" \
all install
endef