aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-06 22:10:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-06 22:10:29 +0000
commit73a5abbb32c4cbf78bc54913f67c2d14de77e758 (patch)
treebc06ccda968103523489e585554a5750bf412657 /package/opkg/Makefile
parentdf535034341a4080b80a4fd27fe337f446f2a904 (diff)
downloadupstream-73a5abbb32c4cbf78bc54913f67c2d14de77e758.tar.gz
upstream-73a5abbb32c4cbf78bc54913f67c2d14de77e758.tar.bz2
upstream-73a5abbb32c4cbf78bc54913f67c2d14de77e758.zip
use $(FPIC) in a few places where it matters
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12225 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/opkg/Makefile')
-rw-r--r--package/opkg/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 6a275ca810..76729db7b1 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -36,6 +36,7 @@ define Package/opkg/description
opkg knows how to install both .ipk and .deb packages.
endef
+TARGET_CFLAGS += $(FPIC)
EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib