aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-16 16:22:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-16 16:22:01 +0000
commit1a6786c4ea06659fc5400f8e476cc1f3070e353c (patch)
tree35c5b7db469ea057d49e4f90c79005427780f1b5 /package/opkg/Makefile
parent543839307a1b71f0c73ae115d75284f3a62d21a2 (diff)
downloadupstream-1a6786c4ea06659fc5400f8e476cc1f3070e353c.tar.gz
upstream-1a6786c4ea06659fc5400f8e476cc1f3070e353c.tar.bz2
upstream-1a6786c4ea06659fc5400f8e476cc1f3070e353c.zip
fix opkg target arch detection problem on x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14055 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/opkg/Makefile')
-rw-r--r--package/opkg/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index d262a70e72..91db724767 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=opkg
PKG_REV:=4564
PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -59,6 +59,7 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
+ HOST_CPU="$(ARCH)" \
all install
endef